webdevqa.jp.net

XCode 4.2.1(SDK5.0)に古いiOSシミュレーターをインストールする方法

新しいiMacを購入しました。次に、最新のSDK 5.0をダウンロードし、XCode 4.2.1をインストールしました。すべてが正常に動作しています。ただし、デバッグに利用できるのはiPhoneおよびiPad Simulator 5.0のみであることに気付きました。それで、[More Simulators]をクリックしました...すべての項目で[Install]をクリックし、しばらく経ってから、戻ったときに「Installed」と表示されました。しかし、XCodeに戻ると、まだシミュレーター5.0だけがリストにあります。

それでは、XCode 4.2.1に古いシミュレータをどのようにインストールしますか?手順を逃しましたか?または、古いSDKをインストールする必要がありますか?助けてください。ありがとう。

36
GeneCode

X-Code 4.2にはiOS 5シミュレーターとライブラリーのみがあります。 X-Codeを備えたより低いバージョンのシミュレーターとライブラリーが必要な場合は、X-Code-> Prefrences->ダウンロードタブ。 [ダウンロード]タブには、次の2つのタブがあります。

1)コンポーネント-iOS 4.3シミュレータ(〜600 Mb)、iOS 4.0-4.1(〜670 MB)デバイスデバッグサポート、iOS 3.0-3.2.2(686.3 MB)をダウンロードするオプションがありますデバイスのデバッグのサポート。

2)ドキュメント-Yoyには、iOS 5.0、XCode 4.2 Developer libaray、Mac OSX 10.7 Core Libraryをダウンロードするオプションがあります。

enter image description here

必要なコンポーネントをインストールし、そこに行きます。このようにコンポーネントをインストールしましたか??

64
rohan-patel

必要なシミュレータがXcodeに表示されない場合は、ここから古いxcodeをダウンロードできます。 https://developer.Apple.com/downloads/index.action?name=Xcode

例えば:

  • iOS 5シミュレーター-> Xcode 4.3
  • iOS 5.1シミュレーター-> Xcode 4.3.3
  • iOS 6シミュレーター-> Xcode 4.6
  • iOS 6.1シミュレーター-> Xcode 4.6.3
  • iOS 7シミュレーター-> Xcode 5
  • iOS 7.1シミュレーター-> Xcode 5.1

ダウンロードした.dmgの中にXcodeアプリケーションがあります。

  1. このDMGを開きます
  2. Xcodeアプリケーションを右クリックし、「パッケージの内容を表示」をクリックします
  3. 以下に移動します:Contents/Developer/Platforms/iPhoneSimulator.platform/Developer
  4. 見つかったシミュレーターフォルダー(例:iPhoneSimulator7.1.sdkフォルダー)をコピーします
  5. 現在のXcodeアプリケーションに対して手順2と3を繰り返します
  6. シミュレーターフォルダーを貼り付けます

Xcodeを再起動すると、新しく追加されたシミュレーターが表示されます

構築とテストが成功しました!

更新:
xCode 6でテスト済み、そこでも動作

14
Antoine