webdevqa.jp.net

iOSシミュレーターには、最新のiOSバージョンのみが一覧表示されます。以前のバージョンを設定するにはどうすればよいですか

ドキュメントによると、シミュレーターが実行するiOSバージョンを選択できるはずですが、「ハードウェア/バージョン」の下にリストされているのは最新の4.3.2のみです。

ヘルプには、「シミュレーション環境で使用するiOSリリースを設定するには、[ハードウェア]> [バージョン]を選択し、テストするバージョンを選択します。」と書かれています。

3.xをサポートしたくありませんが(それは素晴らしいことですが)、少なくとも4.2、4.1、4.0でアプリをシミュレートしたいと思います。どうしたの?なぜリストされていないのですか?

更新:私はLionを使用しているため、以前のバージョンのXcodeをインストールできません。アップグレードする前に、さまざまなバージョンを簡単にテストできました。

18
Tibidabo

問題は、使用できる他のSimulatorSDKがインストールされていないことです。 @doradaが述べているように、Lionを使用しているため、実際には機能しない古いXcodeをインストールする必要があります。 Lionで試したことはありませんが、主にSnowLeopardで以前と同じように機能するはずです。
参照しています 他の回答 古いXcodeを取得する方法(まだ機能しているかどうかはわかりません)

古いバージョンのXcodeを入手したら、イメージをマウントし、ターミナルでナビゲートしてそのボリュームに移動します。隠しフォルダPackagesがあるはずです。そのフォルダをopen .で開き、必要な2つの.pkgファイル(例:iPhoneSDK4_0.pkgiPhoneSimulatorSDK4_0.pkg)を見つけて、両方をインストールします。

それらはルートディレクトリに表示され、Developerディレクトリに移動する必要があります(単に上書きするのではなく、他のすべてのSDKを削除します。最後の別のフォルダに移動してiPhoneSimulator4.0.sdk\にする必要があります。そしてそれをコピーします)

完了(その時点で確認しました。Lionで動作します。3.2.1からバックアップを開始したDVDイメージを使用しました)

16
user207616

古いiossdk/xcodeをからダウンロードできます。 https://developer.Apple.com/downloads/index.action

(私は実際に別のスタックオーバーフロートピックでこの答えを見つけましたが、今はその質問を見つけることができないようです!)

3
Shrouk Khan

Xcodeを開き、左上のメニューで実行するデバイスを選択し、[その他のシミュレーター...]をクリックします。

Xcode設定のダウンロードセクションが開きます。

「コンポーネント」タブをクリックします。

インストールできるシミュレーターのリストが表示されたら、必要なバージョンで[インストール]をクリックします。

シミュレータをインストールするには、再起動する必要があります。

新しくインストールされたバージョンのシミュレーターを実行するには、Xcodeの実行メニューからそれを選択するだけです。

2
Paul Herron

SnowLeopard用のXcode4.2をインストールした後、iPad 3.2 Simulatorの選択肢があることに気付きましたが、それを使用すると、「iOSSimulatorがSDKを見つけられませんでした。SDKを再インストールする必要があるかもしれません」というアラートが表示されます。 「シミュレートされたアプリケーションが終了しました。再起動をクリックして再試行してください。」という別のアラート。 [終了]、[SDKの切り替え]、および[再起動]ボタンを使用します。

IPhone 4.0 Simulator、iPhone 4.1 Simulator、iPad 4.2SimulatorなどをiPad/iPhone 5.0 Simulatorまで正常に使用できますが、可能であればiPad 3.2SimulatorとiPhone3.1.3Simulator以前を3.0まで使用したいと考えています。

私たちのアプリは通常3.0までさかのぼって実行され、以前のiOSユーザーからバグレポートを受け取ることがあります。これらの問題をより効果的にデバッグできるようにしたいと考えています。

Tibidaboによって要約された手法を試しましたが、前述のようにシミュレーターフォルダーをコピーでき、Xcodeに選択肢として表示されますが、実際にシミュレーターとして実行することはできず、上記と同じ問題アラートが表示されます。

古いiOSバージョンのデバッグをサポートするために他の開発者は何をしていますか?

1
Rei

実際には、以前のシミュレータバージョンをインストールする必要がありますが、新しいインストールではインストールされません。

たぶん、どこかで検索してダウンロードできますか? -オフィスの共有ドライブに保管しています。

1
Daniel Broad