webdevqa.jp.net

プロジェクトファセットJavaバージョン1.7はサポートされていません

Javaを更新すると、「プロジェクトファセットJavaバージョン1.7はサポートされていません」)という問題が見つかりました。この問題を解決するには、手順に従ってください。

  1. Ecllipseに移動し、プロジェクトフォルダーを右クリックします
  2. プロパティを選択
  3. ここでProject Facetsを選択します。ここでJavaが表示されます。バージョンをクリックし、必要に応じてバージョンを低くするか、変更します。

enter image description here

33
Imran khan

IDEにインストールされているJREのタイプを確認する必要があります。

JRE

5
Boopathi

しばらく前にJavaバージョン1.6から1.7にアップグレードするときに同じ問題に遭遇しました。これを解決するには、以下の手順に従いました。

  1. プロジェクトエクスプローラでプロジェクトを右クリックし、[プロパティ]をクリックします。
  2. Java Build Path>“ Libraries”に移動します
  3. アイコンに赤い十字マークが付いている競合ライブラリを削除します。
  4. 必要に応じて、JREシステムライブラリジャーを確認および編集します。
  5. Project Facetsに移動し、必要なJavaバージョンを選択します。

ソース: https://tipandtech.wordpress.com/2013/09/13/error-project-facet-Java-version-1-7-is-not-supported-in-Eclipse/

まだ解決策が見つからない場合は試してください。

ししる

4
Shishir Kumar

私はちょうど同じことをしました。私の解決策は、インストールされたJREの1.6 JREを削除し、Java 1.7の1つにチェックを入れることでした。

これは、[ウィンドウ]-> [設定]-> Java->インストール済みのJRE

ブーパティが言うように。

3
Allan D

Tomcatサーバーをダブルクリック->ランタイム環境->インストール済みjre-> jdk 1.7を選択

2
user2369634

Window-> Preferences-> JavaコンパイラでJDKのバージョンを確認し、Window-> Preferences-> Project Facets-> Javaで同じJDKを設定します

0
Anand Kumar

1.ウィンドウメニュー->環境設定2.左側で、サーバー->ランタイム環境を選択3.ハイライトプロジェクトに使用するサーバーを選択し、「編集…」ボタンを選択4。 Server Runtime Environment」ダイアログで、JREをJava 7 JDKまたはJREに変更します。5。プロジェクトを再ビルドすると、エラーはなくなります。

0
Akshay Salvi

サーバー(Tomcatなど)が指すjreをJREではなくJDKに変更します。

0
Vivek