webdevqa.jp.net

Android Studio-Gradle同期エラー

Android Studioで同期エラーが発生します。カナリアチャネルの1.0.2バージョンを使用しています。Gradle:Iバージョン2.2.1( https://www.gradle.org/downloads からダウンロード)と自己ダウンロードバージョン[〜#〜] jdk [ 〜#〜]:jdk1.8.0_05

新しいプロジェクトを作成しましたが、エラーは常に同じです: enter image description here

エラー:メソッド 'org.objectweb.asm.ClassReader.getMaxStringLength()I'が見つかりません。この予期しないエラーの考えられる原因は次のとおりです。

  • Gradleの依存関係キャッシュが破損している可能性があります(ネットワーク接続のタイムアウト後に発生する場合があります)。

キャッシュメソッドの無効化Gradleデーモンの停止で問題を解決しようとしました-)、しかし何も..

16

ホームディレクトリとプロジェクトのトップレベルの両方にある.gradleディレクトリを削除します。 Gradleのキャッシュディレクトリは、[キャッシュをクリアして再起動]オプションの影響を受けません。

25
Scott Barta

Android Studio 2.3に更新した後、このエラーが発生し、トップアンサーが機能しませんでした。 こちら からのアンサーに従って、ようやく修正しました。

に行く

gradle→ラッパー→gradle.wrapper.properties

そして、distributionUrlを次のように変更します。

distributionUrl=https\://services.gradle.org/distributions/gradle-3.4.1-all.Zip
1
John Snow

遅い回答で申し訳ありませんが、それがまだ役立つことを願っています。私も同じ問題に直面し、.gradleディレクトリを削除しても解決しませんでした。

JDKを再インストールしてみてください。私の場合、JDK 1.7.0_60(x64)とJDK 1.8.0_5(x86)をアンインストールしました。次に、JDK 1.8.0_45(x64)をインストールしましたが、問題は解決しました。 HTH。

0
kor88