webdevqa.jp.net

Eclipseを起動できません - Javaは起動しましたが終了コード= 13を返しました

私はEclipseを使ったAndroid開発の私の最初の趣味を手に入れようとしています。ほんの数分前にバージョン4.2をインストールしたEclipseを実行しようとしたとき、私はこの問題に遭遇しました。

最初にJava VMを指定するためのパラメーターなしでEclipseを起動しようとした後、couldn't find a Java VM called javaw.exe inside the Eclipse folderというエラーメッセージが表示されたので、Javaがインストールされている場所を見つけ、ショートカットのターゲットのパラメーターとしてその場所を指定しました。今度は別のエラーJava was started but returned exit code=13を受け取ります。

これは32ビット/ 64ビットの競合であることを示しているように思えますが、64ビット版のEclipseとJava (RE 7u5)の両方の64ビット版をダウンロードしたことは99%前向きです。

  • 私のEclipseとJavaが64ビットであることを確認する方法を誰かが知っていれば、それは高く評価されるでしょう。
  • 私の問題は別の問題だと思うなら、助けてください!
  • 私はEclipseとJavaにまったく慣れていないので、できるだけわかりやすく話してください。

ショートカットのターゲット: "C:¥Program Files¥Eclipse-SDK-4.2-win32-x86_64¥Eclipse¥eclipse.exe" -vm "C:¥Program Files(x86)¥Java¥jre7¥bin¥javaw.exe"

完全なエラーコード...:

Java was started but returned exit code=13
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\Eclipse\\plugins/org.Eclipse.equinox.launcher_1.30v20120522-1813.jar
-os win32
-ws win32
-Arch x86_64
-showsplash C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\Eclipse\\plugins\org.Eclipse.platform_4.2.0.v201206081400\splash.bmp
-launcher C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\Eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\Eclipse\\plugins/org.Eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v201205221813\Eclipse_1503.dll
-startup C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\Eclipse\\plugins/org.Eclipse.equinox.launcher_1.30v20120522-1813.jar
--launcher.overrideVmargs
-exitdata 1e30_5c
-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\Eclipse\\plugins/org.Eclipse.equinox.launcher_1.30v20120522-1813.jar
901
Ben E.

OS、JDK、およびEclipseのビット数の実用的な組み合わせがあります。私の場合は、64ビットOS上で64ビットJDKと32ビットEclipseを使用していました。 JDKを32ビットにダウングレードした後、Eclipseは動き始めました。

次の組み合わせのいずれかを使用してください。

  • 32ビットOS、32ビットJDK、32ビットEclipse(32ビットのみ)
  • 64ビットOS、32ビットJDK、32ビットEclipse
  • 64ビットOS、64ビットJDK、64ビットEclipse(64ビットのみ)
166
tk_

Eclipseのバージョンは、パスとファイル名に基づいて64ビットです。しかし、現在入手しているJavaのバージョンは32ビットです。

-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe

Program Files (x86)は、64ビットWindowsが 32ビット programsを配置するフォルダです。

Program Filesは、64ビットWindowsが 64-bit programsを配置するフォルダです。

これは、Windows 64ビットでよく見られるように、システムに複数のJVMがインストールされている場合に発生する可能性があります(たとえば、JREダウンロードページでは、ブラウザのビットネスを使用して提供されます)。 64ビットWindowsを実行しているにもかかわらず、多くの人が(d)32ビットブラウザを使用しています。

実際にシステムに64ビットのJREまたはJDKがインストールされていると仮定してこれを修正する最善の方法は、Eclipse.iniに使用するJVMを正確に指定することです。その手順は Eclipse wikiページ で詳細に説明されていますが、基本的にはiniファイルで-vmオプションを指定する必要があります - フォーマットは非常に特定なのでwikiページを注意深く読むようにしてください。

Eclipse.iniでJVMパスを指定することを強くお勧めします。そうすることで、一部のプログラムインストーラーが行う可能性のあるシステムPATHに対するEclipseからのEclipseの分離を隔離するためです(私はOracleに話しています)。

もう1つの選択肢は、64ビットではなく32ビットのEclipseをダウンロードして使用することですが、それでもEclipse.iniにJVMへのパスを指定することを強くお勧めします。


履歴の参照用に左

Javaのバージョンを確認するには、次のコマンドを実行してください。

 Javaバージョン

コンソールで(コマンドプロンプト)。 64ビットJava 6を搭載したWindows 7では、次のようになります。

 Javaバージョン "1.6.0_27" 
 Java(TM)SEランタイム環境(build 1.6.0_27-b07)
 Java HotSpot(TM)64ビットサーバーVM(ビルド20.2-b06、混合モード)

3行目に注意してください。これは、これが64ビットバージョンであることを示しています。

32ビット版では、次のようになります。

 Java HotSpot(TM)クライアントVM(ビルド20.1-b02、混合モード、共有)
707
DNA

私はこのエラーを受け取り、私のPATH変数(Windows上)がおそらく変更されていることを知りました。私のPATHで最初にこのエントリでした:

C:\ProgramData\Oracle\Java\javapath

...そしてEclipseは"C:\ProgramData\Oracle\Java\javapath\javaw"を実行しました - それはエラーを与えました。これは、Java 8のインストールに伴って発生したものと思われます。

私はいくつかのJavaバージョン(6、7、8)をインストールしていたので、PATHからそのエントリを削除し、Eclipseを再起動しようとしましたが、これはうまくいきました。

それがうまくいかない場合は、JDKをアップグレードする必要があります(この場合はJavaバージョン - 8)。

PATH変数を編集する方法についての指示

238
mortensi

最近Java 8をインストールし、Java 7をアンインストールした場合は、JDK 8をインストールして再試行してください。

179
Jaswanth Kumar

私にとっての解決策は、(Windows 8.1では)次のようになることでした。

System > Advanced system setting > Environment Variables 

'Path'変数の 'System variables'の下に、最初に次のものがありました。

C:\ProgramData\Oracle\Java\javapath;

私はこれを取り除きました、そしてEclipseは再び働きました!

117
RustyIngles

私は同じ問題を抱えていた、 Javaが開始されたが終了コード= 13を返した

私の解決策はWindowsのプロパティに環境変数を作成することでした 変数名 = PATH 変数値 = C:\ Program Files\Java\jdk1.7.0_02\bin ではなく C:¥Program Files(x86)¥Java¥jre7¥bin に移動します。

次に、ファイルEclipse.ini→C:¥Program Files¥Java¥jdk1.7.0_02¥bin¥javaw.exeに1行追加しました。

それは私のために働いた。

63
Katusepi

enter image description here

この問題は以下の手順で修正されました。

  1. Eclipseは 'C:\ ProgramData\Oracle\Java\javapath'からJava実行ファイルを見つけます。

  2. フォルダ構造には、以下の実行ファイルへのショートカットが含まれています。
    私。 Java.exe
    ii。 javaw.exe
    iii。 javaws.exe

  3. 私にとっては、実行可能パスはmy Program Files(x86) (32ビットアプリケーション用のホーム)フォルダの場所を指していました。

  4. 私はそれを Program Files (64-bitアプリケーションがある)に修正し、問題は解決しました

同じスクリーンショットを見つけてください。

23
dreamdeveloper

これまでで最も奇妙な修正。 Eclipseのパスを調べて、変な文字(!#@など)がないことを確認してください。それは私のために働きました。

21
bello

.iniファイルにvm引数を追加するとうまくいきました

-vm
C:\Program Files\Java\jdk1.7.0_65\bin\javaw.exe
20
TastyCode

Java Update 25をアンインストールしたところ、問題は解決しました。

10
Shetty's

Eclipse.iniを見つけます。

しばしばC:\Users\xxx\Eclipse\jee-neon\Eclipseで、追加

-vm
 C:\Program Files (x86)\Java\jre7\bin\javaw.exe

後に

--launcher.appendVmargs
10
Pythoner

Java JDK のクリーンな再インストールは私の場合トリックをしました。私は実行しています Eclipse 4.4 (Luna)は今魅力のようです。

10
Benjamin Todts

32ビットのJavaランタイムしかインストールされていないことがわかりました。

C:\Program Files (x86)\Java\jre1.8.0_45\

Eclipseが本当に望んでいたのは、私に64ビットJavaランタイムをインストールすることだけでした。 <= SOLVED

Java SE Runtime Environment 8u45  jdk-8u45-windows-x64.exe

http://www.Oracle.com/technetwork/Java/javase/downloads/jre8-downloads-2133155.html

Confirm your installation by checking you now have this folder

    C:\Program Files\Java\jre1.8.0_45\
9
hamish

JDKのインストールを忘れたときにこのメッセージが表示されました。

9
Patricia Beier

ここでの最善の答えは長すぎます。コメントできないので回答を追加しました。

  1. ここに行きます: http://www.Oracle.com/technetwork/Java/javase/downloads/index.html
  2. 最新のSDKをダウンロードしてください(もちろんあなたのコンピュータがx64ならx64です)。
  3. それをインストール
  4. これでパーティーは終了しました。次にEclipseで作業します。
8
fresko

解決策は簡単です: "Eclipse"フォルダを "C:/ Program Files"に置いてください。うまくいかない場合は、「C:/ Program Files(x86)」に入れてください。

8
blueray

私は同じ問題を抱えていました。私は64ビットOSでWindows 8を使用していました。パスをProgram Files (x86)に変更したところ、作業が始まりました。この行をEclipse.iniファイルに入れます。

-vm
 C:\Program Files (x86)\Java\jre7\bin\javaw.exe
7
Pir Fahim Shah

32ビットJREを搭載したPCに64ビットEclipseバージョンをインストールした場合、これが起こることが保証されています。

だから解決策は非常に簡単です:あなたはどちらかを更新することによってそれらを同期させる必要があります。これは、Oracle Fusionミドルウェアをダウンロードする際に、JREが64ビットでJavaホームが64ビットJDKを指しているのにEclipseが32ビット環境を想定している場合に発生します。

Eclipseパスに特殊文字(%$#など)がないことを確認してください。

6
Asokan
  1. システム環境変数で、 "C:¥ProgramData¥Oracle¥Java¥javapath"が削除されていることを確認してください。

  2. システム環境変数の下に、 "C:¥Program Files¥Java¥jdk1.8.0_131¥bin"が追加されていることを確認してください。

enter image description here

6
Siddarth Kanted

私は次の解決策を試しました:

パス C:¥Program Files¥Java¥jdk1.7.0_71¥bin からjavaw.exeのショートカットを作成し、パス C:¥ProgramData¥Oracle¥Java¥javapath に貼り付けました。

その後、私はEclipseを立ち上げました、そしてそれは私のために働きました。

5
Jitendra

私も同じ問題に遭遇しました。環境変数 Path が誤ったJavaバージョンを指していることがわかりました。

環境変数を確認して、正しいJavaを指定してください。例えば:

C:\Program Files (x86)\Java\jdk1.6.0_17\bin

環境変数を確認するには、以下に進みます。

Computer → properties → Advanced system settings → Advanced -> Environment variables
5
Touchstone

私はこの問題を抱えていました。 Chrome 8経由でJava 8 update 25をインストールしましたが、Eclipseを起動しようとしたところ、前述のエラーが発生しました。

そのアップデートをアンインストールすると、Eclipseは再び動作します。

5
mtyson

解決策をいくつか試しましたが、うまくいきませんでした。

最後に、私は別の方法を見つけました、...

環境変数 システム変数 に移動します。

C:¥Program Files¥Java¥jdk1.7.0_02¥bin¥javaw.exe をシステム変数のパスに設定します。

それを試してみてください。それは私のために働きました...

5
Kandy

JDKを1.7から1.8にアップグレードした後も同じ問題がありました。私はEclipse 4.4(Luna)を使っています。 JDKを1.7に下げた後、エラーはなくなりました。

4
sh977218

環境変数セクションで2つのJavaパスを設定したかどうかを確認してください。 JDKの2つのバージョンをすでにインストールしている場合は、それがインストールされている可能性があります。次に、PATHをJava用に配置したことを再確認します。

PATH -->  C:\ProgramData\Oracle\Java\javapath

そしてまた

Java_HOME ---> C:\Program Files\Java\jdk1.7.0_02\bin

両方がある場合、この種のエラーが発生する可能性があります。

問題がなければ、 ".ini"ファイルをチェックインして、下の部分が問題ないか確認してください。 「.ini」ファイルを開いて確認する

 -VM  path is  C:\Program Files\Java\jdk1.7.0_79\bin\

そうでなかったら、それをそのように設定し、再度実行してください。

4
dush88c

メモリ不足の可能性があります。 Eclipse.iniファイルを変更してメモリーを増やすことができます。FAQ Eclipseで利用可能なヒープサイズを増やすにはどうすればいいですか?

4
vishal129

私はちょうど私のWindows 8.1 PCをセットアップする際に同じ問題を解決しました。上記の@George Papatheodorouとまったく同じように(申し訳ありませんがコメントを追加できません)、EclipseとJREは両方とも64ビットまたは32ビットでなければなりません。

ただし、Windows 8/8.1環境の場合は、32ビットのJREがデフォルトで取得されます(ダウンロード用にそのデフォルトを変更する場所がわかりません)。 http:// Java。 com/ja/download/faq/win8_faq.xml

私は64ビットEclipseを使用していたので矛盾がありました。それから私は32ビットのEclipseをインストールしました、そして今回はすべてうまくいきます。

そのため、環境変数の変更を気にする前に、JREとEclipseのバージョンを確認してください。

もちろん、64ビットEclipseで64ビットJREを使用することができます。 Windows 8.1ではデフォルトで32ビットが提供されるので、それらが一致することを確認してください。

4
Fenwick

私のWindows 7システム、64ビットシステムにJava 8をインストールした後、私は同じようなエラーがありました。

環境変数の変更などは役に立ちませんでした。だから私はJava Update 8を削除しようとしましたが、それも助けにはなりませんでした。 64ビット版のJava 8 SDKをダウンロードしてインストールすることで問題が解決しました。これが役に立つことを願っています。

4
IrfanClemson

この種のエラーは基本的に、Eclipseのバージョンが異なるとJavaのバージョンが異なるために発生します。

システムに64ビットJDKをインストールしているとします。それから64ビット版のEclipseを必ずインストールしてください。

また、システムに32ビットJDKをインストールする場合は、必ず32ビットバージョンのEclipseをインストールしてください。

私は同様の問題を抱えていました。私は32ビットJDKをインストールし、64ビットEclipseを使用しようとしていました。

私のシステムに64ビットJDKをインストールしたとき、Eclipseは問題なく動作し始めました。

32ビット版のEclipseと32ビット版のEclipseを32ビット構成のシステムにインストールすることをお勧めします。64ビットシステムの場合も同様です。

これにより、システムのパフォーマンスが向上します。

3

既存の回答に大きな価値を追加するリスクはありませんが、この混乱をすべて自分で経験したので、問題への対処方法を統合できるかどうかを確認したいと思います。

  1. 通常のマシン環境とは別個の開発を維持します。その理由は、おそらく銀行やセキュリティアプリケーションなど、Javaを時々更新する必要があることに気づいていないマシンで実行されている多くのアプリケーションがあるからです。これらの更新が行われると、環境変数が変更されるため、開発環境でそれらを使用している場合、更新によってEclipseセットアップがほぼ確実に中断されます。

  2. プラグインなどに応じて32ビットと64ビットのEclipseのバージョンをインストールします。多くのプラグインはまだ32ビットを必要とし、それらを64ビット環境にインストールしようとすると、多くの不明瞭(非常に不明瞭)エラーが発生します。これは、たとえば、Java EE、PHP、Python、アセンブラなどの開発環境用にEclipseの個別のインスタンスが必要になる場合があることを意味します。これは厄介に思えるかもしれませんが、私にとってこれは祝福でした。

  3. もう一度32ビットと64ビットの2つのJavaランタイムをインストールし、インストールごとにEclipse.iniを編集して、正しいJREを指すようにしますnot環境内のJREホーム変数。 C:\Java\64bit\jdk1.7.0_15\およびC:\Java\32bit\etcにディレクトリを作成し、Eclipse.iniファイルに-vm C:\Java\64bit\jdk1.7.0_15\bin行を追加して、必要なJavaランタイムを指定します。

上記が完了したら、Java SDKのアップデートを好きなだけインストールできますが、開発環境が壊れることはありません。開発ランタイム環境を更新する必要がある場合は、Eclipse.iniの-vmパスを変更するだけです

2
Alexander

それでもうまくいかない場合は、コンピュータからJavaを完全にアンインストールしてから再度インストールし、パス変数が正しく設定されていることを確認してください。

2
kapil thadani

私はx 64ビットJDKを持っていました。私のパス設定には何もありませんでした。そこで私はx86 JDKをインストールしました。これで私の問題は完全に解決した。

2
Sabri Meviş

同じマシン上に複数のバージョンのJavaがある場合、これが起こる可能性があります。これを修正するために、私は以下をしました:

  1. 現在のJava_HOMEの値を確認してください。 Windowsでは、エコー%Java_HOME%
  2. Javaw.exeの経路にアクセスしました
  3. Javaホームの場所を指すショートカットを置き換えました。
2
user1336321

私は以前にJREをインストールしたことがあったのに対し、私はJDK(v7 update 80)をインストールすることによってこの問題を解決しました。

注:これはIBMの _ rtc _ ソフトウェア(Eclipse上に構築されたもの)のためのものです。

1
James Wierzba

誤って32ビットのEclipseをインストールしていて、64ビットのJREで使用しようとしていたため、このエラーが発生しました。 32ビットまたは64ビットのEclipseがインストールされているかどうかを確認するには、次の回答を参照してください。 https://stackoverflow.com/a/9578565/191761

1
Kidburla

私は同じ問題に直面していました。私はバージョン8をインストールし、25 32ビットを更新しました。

解決するには、Java SE Development Kit 7 Update 71(64ビット)をインストールしてください。次にappwiz.cplを使用して、他のバージョン、すなわちJava Update 25を削除します。完了。

1
Girish Sakhare

一番上の答えは私にはうまくいきませんでした。私は、Javaパスを定義する環境変数がないか、パスにJavaがありませんでした。

ただし、Eclipse.iniファイルで上書きしようとしても、パスC:¥ProgramData¥Oracle¥Java¥javapath¥javaw.exeが常に-vmオプションのEclipse 4.5(Mars)エラーポップアップに表示されていました。

これを回避するには、コマンドプロンプトを開き、Eclipse.exeがあったディレクトリをcdして MKLink を使用します。

C:\EclipseMars> mklink javaw.exe "C:\Program Files\Java\jdk1.7.0_79\bin"
symbolic link created for javaw.exe <<===>> C:\Program Files\Java\jdk1.7.0_79\bin

Eclipse.iniを変更する必要はありませんでした。

Eclipse.iniで-vmオプションを指定しようとしましたが、それが考慮されましたが、Eclipse.iniに1つの-vmしかない場合でも、エラーポップアップで-vmオプションが2回表示されました。

私のEclipse.iniには-vmオプションがなく、シンボリックリンクだけで修正されたようです。

1
The HCD

マシンに複数のJavaバージョンがインストールされている場合、Eclipseにjavaw.exeの使用元と使用元を指示するだけです。

私の場合、IBM JDKとOracle JDKもありますが、Eclipseをピックアップするために、EclipseディレクトリのEclipse.iniファイルに以下の行を追加しました。

-vm
C:/WAS9DEV/Java/8.0/bin/javaw.exe

上記の例では、Javaフォルダーへのパスを置き換える必要があります

それが役に立てば幸い。

0
minigeek

Eclipseがインストールされているフォルダーに移動してから、Eclipse.iniファイルを変更する必要があります。

あなたが追加する必要があります

-vm

C:¥Program Files¥Java¥jdk1.8.0_202¥bin¥javaw.exe

Eclipse.iniファイルは以下のスクリーンショットのようになります。

enter image description here

0
Saurabh Prakash