webdevqa.jp.net

Eclipseエラー:このプロジェクトはWTPメタデータを移行する必要があります

私たちは、Eclipse 3.2でWebプロジェクトを開始し、それからEclipse 3.4にアップグレードしましたが、プロジェクトにエラーが発生しました。

「このプロジェクトはWTPメタデータを移行する必要があります」

右クリックして、実際にWTPメタデータを移行する「クイックフィックス」を試してみました。残念ながら何も起こらず、エラーが残ります。

問題からそのエラーを削除することができ、すべてが正常に機能しますが、ソース管理からプロジェクトを再インポートするたびにエラーが再表示されます。このエラーを永久に取り除く方法や、WTPメタデータを実際に移行する方法に関するアイデアはありますか?

PDATE:全員、前の人の答えを参照する独自の答えを追加するのではなく、あなたに合った答えに投票してください。

56
larf311

上記のソリューションは正常に機能しますが、何度も繰り返し表示されます。より簡単な解決策は、Eclipseで関連するプロジェクトを右クリックし、検証を選択することです。

127
Nuts

私にとっては、これらのどれも機能しませんでした。私にとっての解決策は、Eclipseが停止している間に次のファイルを削除することでした。

/workspace/.metadata/.plugins/org.Eclipse.core.resources/.projects/myprojectname/.markers
25
Milan

ここにあなたが試すことができる別のものがあります、これだけが私のために働いた:(

プロジェクトのプロパティ>プロジェクトファセットに移動し、「Java」と「Utility Module」にチェックマークを付けます...適用するプロジェクトが他のプロジェクトから参照されている場合は機能します。そうでなければ、これらのオプションで再生できます... 。

8
marius

.projectファイルにこの行を追加してみてください

<nature>org.Eclipse.wst.common.project.facet.core.nature</nature>

または この説明 を参照してください。たとえば、.sessions/org.Eclipse.wst.common.componentに重複したエントリがないことを確認してください


larf311 のコメントに記載されているように、このインスタンスの実際の答えは次のとおりです。

.settings/org.Eclipse.wst.common.component」ファイルを削除します。

シンプル。 ;)

4
VonC

これは、wtpのプロジェクト構成が古いか、モジュール間に競合があることを意味します。 [プロジェクト]-> [プロパティ]-> [プロジェクトファセット]に移動します。次に、以下をクリックします:動的Webプロジェクトバージョン2.5、Java 5または6およびjavascriptツールキット(必要かどうかは不明)。settingsファイルに変更が加えられていることがわかります。チェックイン新しい変更、そして誰かがプロジェクトをチェックアウトするたびに大丈夫

2
Moataz Elmasry

.markersファイルを削除すると、この問題は解決しました。私はそうするための「評判」を持っていないことを除いて、私はその解決策を支持します。 :(

2
Michael Lamb

プロジェクトを削除し、ソース管理からチェックアウトします

0
Richard

プロジェクトの[プロパティ]で[プロジェクトファセット]を選択しました。何も選択されていませんでしたが、右側にJava 1.3以降を選択する必要があることを示すメッセージがありました。私はJava 6以降を選択しましたプロパティウィンドウを閉じると、「検証」を行う必要がありましたが、問題はようやく消えました。

0
april26

Maven ... mvn Eclipse:clean ... mvn Eclipse:eclipse ...プロジェクトを再インポートします

0
mortsahl

SVNを使用し、新しいコンピューターでプロジェクトをチェックアウトするたびにこの問題が発生します。修正する方法は、.settingsを元の場所からプロジェクトの新しいフォルダーにコピーすることです。もちろん検証を使用します

0
Cesar Olvera