webdevqa.jp.net

Eclipse内部エラー「Polling news feeds」

私は私のMacBook(High Sierra、Java 11)でEclipse(4.9.0)を使っていますが、このエラーは時々見られています。 Eclipseに戻って毎回このエラーを閉じるのは面倒です。誰かが私がこれを解決するのを手伝ってくれる?

The error showing up after a while using another app

51

EclipseがJava 11で動かされるとき、これは確かに問題であるようです。私はこれを報告するために Bug 539545 を作成しました。

当面の間は、ニュースフィードのポーリングを無効にすることでこの問題を回避できます。これを行うには、 設定... - >一般 - >ニュース の順に進み、 自動ニュースポーリングを有効にする オプションをオフにします。

Preferences news feed disabling

エラーウィンドウは表示されなくなります。

108
Pyves

これは http://openjdk.Java.net/jeps/320 - が原因で発生します。これは、標準のJava 11バージョンからJava EEおよびCORBAモジュールが削除されたものです。

@Pyvesで述べたように、簡単な方法はPreferences - > General - > Newsから "Enable automatic news polling"のチェックを外してください。

それでもこれが必要な場合は、Eclipseの軌道リポジトリから "javax。*"バンドルをインストールできます。これが最新の安定したレポジトリです。 http://download.Eclipse.org/tools/orbit/downloads/drops/R20180905201904/repository

enter image description here

17
Kondal Kolipaka

ニュースフィードをオフにすることでこの問題は解決します(@Pyvesによる、Preferences - > General - > Newsから "Enable news news polling"のチェックを外してください)、 しかし 他の問題もあります。 - 新しいJDK。 Noga Rotmanは、EclipseがJUnitが正しくインストールされていてもクラスパス上にあるにもかかわらず、JUnitを見つけることができないことが、同じJDK(同じ問題を引き起こしているもの)を使用するためであると考えました。

現在のバージョンのJDKをアンインストールし、古いバージョンをインストールしてからEclipseを再インストールすることで、根本的な問題を解決できます。 Oracle JDKをお持ちの場合は、アンインストール手順 here およびJava SE Development Kit 8u191(これは私の問題を解決しました)は here です。

2
Lea Kissner