webdevqa.jp.net

IntelliJ IDEA 2016.1(64):Unsupported Java version cannot be under under Java 1.7.0_79-b15:Java 1.8以降が必要

現在、Java_HOME環境変数を1.7に設定しています

ファイルidea64.exe(パス:..\JetBrains\IntelliJ IDEA 2016.1\bin\idea64.exe)を開こうとすると、以下のエラーが入力されます

enter image description here

サポートされていませんJavaバージョン
Java 1.7.0_79-b15:Java 1.8以降が必要です。

上記のエラーから、Java_HOMEを1.8に設定する必要があることがわかりましたが、Java_HOMEを1.8に設定したくありません。

私はJava-8をポイントしてこれを修正できる構成ファイルがあるはずだと思いますが、誰でもどこで構成変更を行うことができるか教えてもらえますか?

14
user2587669

IDEA_JDK_64環境変数を作成し、その値をコンピューター上のJDK8インスタンスの場所に設定する必要があります。

このJDK8インスタンスはideaにのみ使用でき、Java_HOMEはJava 7を同時に指すことができ、問題はありません。

ドキュメント

idea64.exeは次のJDK検索シーケンスを使用します。

  • IDEA_JDK_64環境変数
  • ..\jre64ディレクトリ
  • システムレジストリ
  • JDK_HOME環境変数
  • Java_HOME環境変数
26
Cootri

現在のJDK 8インストールを指すIDEA_JDK_64環境変数の作成は、Windows 7では機能しませんでした。

うまくいったことは、IDEAにあるスクリプトから開始しました:

<your location of>\IntelliJ IDEA Community Edition 2016.1.1\bin\idea.bat

Windowsでは、ショートカットをその場所にマップし、アイコンを次のように変更できます。

<your location of>\IntelliJ IDEA Community Edition 2016.1.1\bin\idea.ico

1