webdevqa.jp.net

エラー:少なくとも1つのpostgresql-client- <version>パッケージをインストールする必要があります

UbuntuにPostgreSQLをインストールしようとしています。

私は次の指示に従いました:

/opt/PostgreSQL/9.0/doc/postgresql/html/installation.html 

postgreSQLは正常にインストールされたようですが、インストール後のセットアップとして、次のように求められました。

これを行うには、~/.bash_profile(またはすべてのユーザーに影響を与える場合は/etc/profile)などのシェル起動ファイルに以下を追加します。

PATH=/usr/local/pgsql/bin:$PATH
export PATH

しかし、私は.bash_profileがどこにあるのかわかりません。これは必要ないと言ったのでスキップし、データベース(createdb mydb)を作成しようとすると、

エラー:

You must install at least one postgresql-client-<version> package.

それが何であるか私にはわかりません。このエラーが発生する理由と、postgresql-clientをインストールする方法を誰かが説明できますか?

19
Guest

本当に今9.0が必要ですか?それ以外の場合は、優れたビルド済みパッケージを使用してください。

Sudo apt-get install postgresql-8.4 postgresql-client-8.4

ubuntu 10.10で私が持っているものです。

9.0にする必要がある場合は、Debianパッケージソースから再構築することをお勧めします。

13

Debianベースのシステム(Ubuntu)を使用していて、postgresql-client-commonパッケージがインストールされているが、バイナリを提供するバージョン付きパッケージ(postgresqlなど)がないため、「少なくとも1つはインストールする必要があります...」というエラーが発生します。 -client-8.4、インストール済み。

現在サポートされているPostgreSQLのデータベースクライアントパッケージバージョンを自動的にインストールするpostgresql-clientパッケージをインストールするだけです。

使用しているUbuntuのリリースや、デフォルトで付属しているPostgreSQLのバージョンはわかりませんが、Ubuntu/DebianバージョンのUbuntuのクライアントプログラムを使用せずに、インストールされているバージョンを使用するようにPATHを変更したほうがよい場合があります。

.bash_profileは.bashrcに似ています。作成されていれば、どちらもホームディレクトリにあります。

5
jla

これを〜/ .bashrc(つまり/home/youruser/.bashrc)に追加してみてください。

または実行:

gedit ~/.bashrc

ターミナルから。ファイルにはすでにコードが含まれているはずですが、ファイルの最後に追加してからファイルを保存すれば、問題ありません。

ああ..これを行った後、$ PATHを設定してエクスポートまたは実行できるように、再度ログインします。

PATH=/usr/local/pgsql/bin:$PATH 
export PATH

再ログすることなくターミナルから。うまくいくはずです... :)

1

バージョンを指定したくない場合は、これを使用できます

Sudo apt-get install postgresql-client
0
FacePalm