webdevqa.jp.net

apt-getで異なるバージョンのPython用のpythonパッケージをインストールするにはどうすればよいですか?

Ubuntu 10.10では、python 2.7をインストールしました。apt-getを使用してこのバージョンのpythonにパッケージをインストールしたいのですが、まだインストールしていません。方法を理解することができます。

私が成功せずに試したこと:

/ usr/bin/pythonのシンボリックリンクを/usr/bin/python2.7を指すように変更します-このapt-getを実行した後でも、python2.6にインストールされます。

Update-alternativesを使用して主要な代替手段としてpython2.7を設定します-機能しません。

何か案は?ありがとう!

4

現在サポートされているpythonバージョンのセットは/usr/share/python/debian_defaultsにあります。python-2.7がサポートされているとリストされている場合は常に確認してください。

Debianにはいわゆるpython-supportシステムがあります。 python-support-awareパッケージ(つまり、メンテナがパッケージング中にpython-supportのものを使用した場合)がそれを言うとき Pythonバージョン の特定の範囲をサポートします。 dpkgはpostinstプロセスの一部として インストールされたランタイムの更新をフックします を呼び出します。同じことを行う代替のpython-centralシステムもあります。

1
drdaeman

Python setuptools ?をインストールした後、追加のパッケージをインストールするのは通常、次のように簡単です。

$ easy_install package-name

(インストール方法によってはpython 2.7、Sudoを使用する必要がある場合があります)

3
Doug Harris

リポジトリからの問題のように聞こえますか?
ubuntu noにバグレポートを送信する必要がありますか?
それ以外の場合は、必要な場所に手動でインストールできます:-)(ただし、もちろん、apt-get fooよりも注意が必要です)

0
Warnaud