webdevqa.jp.net

エラー:mongodb:不明なバージョン:mountain_lion

Macで次の簡単なコマンドを実行しています。

brew upgrade mongodb 

または

brew install mongodb

以下のエラーが発生します:

エラー:mongodb:不明なバージョン:mountain_lion

単純なコマンドmongoを実行すると、これが表示されます

MongoDB Shellバージョンv4.0.3

しかし、サーバーに接続できなかったというエラーが表示されます

-注目に値します、私は昨晩コマンドラインをいじっていて、どういうわけか私のマシン上のmongodbからすべてのデータベースを削除しました(私は思う)。 mongodbをインストールまたは更新しようとすると、常に上記のエラーが発生します。

私はmongoDBを「初めて」使用しましたが、過去5〜6か月間にそれを使用していくつかのフルスタックプロジェクトを作成しました。何をしたかわかりませんが、vscodeプロジェクトにデータがあるにもかかわらず、エラーが発生したため、node db/seeds.jsも実行できません。

助けてくれてありがとう。

29
Tray Fleary

Formula mongodbがhomebrew-coreから削除されました。チェック pr-4377 自作コアから

ユーザーへ:mongodbが機能しなくなったためにここに来た場合は、非オープンソースライセンスに移行されたため、Homebrewコア式から削除しました。

幸いにも、mongodbのチームはカスタムHomebrewタップを維持していました。古いmongodbをアンインストールし、新しいタップから新しいものを再インストールできます。

brew services stop mongodb
brew uninstall mongodb

brew tap mongodb/brew
brew install mongodb-community
brew services start mongodb-community

詳細は mongodb/homebrew-brew を確認してください。

68
Simba

MongoDBは自作のタップを維持しています。ですから、mongodbをセットアップするための推奨される方法だと思います。自作のタップからmongodbを実行している場合、どちらも同じconfigファイルとdbファイルを使用しているため、mongodbのインストールを変更しても安全です。

# -> Firstly, it's a good reflex to run the following command, to ensure that you don't have any other error
brew doctor
# -> Secondly, ensure that mongodb is not running, in your case, this command will return, probably, "mongodb: unknown version :mountain_lion"
brew services stop mongodb
# -> Install the homebrew tap
brew tap mongodb/brew
# -> Uninstall old homebrew, maybe you will have to rerun this command later with --force flag
brew uninstall mongodb
# -> Install mongodb from mongodb tap
brew install mongodb-community
# -> Ensure that you can access your db, and everything is working, then you can run uninstall again with --force flag.
11
Nainterceptor

mongodbbrewから削除されたため、次のことを行う必要があります。

1)which mongoインストールを確認する場合

2)brew uninstall mongodb

3)brew install mongodb-community

4)brew services start mongodb-community

そして準備ができて!!!

0