webdevqa.jp.net

Lion(10.7)Convert(1)をサポートしていません。 Dylibエラー

Convert(1)を使用しようとすると、次のエラーが発生します。

dyld: Library not loaded: /System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries/libclparser.dylib
Referenced from: /usr/local/bin/convert
Reason: image not found
Trace/BPT trap: 5

どうすれば修正できるでしょうか?

36

ImageMagickの自作インストールでこのエラーも発生していました。パスカルと同じ線に沿って、私はそれを修正しました

  1. XCode 4.1をインストールします(App Storeから)
  2. Xcodeで、[Xcode]> [設定...]> [ダウンロード]タブに移動し、[コマンドラインツール]の横にある[インストール]をクリックします
  3. brew uninstall imagemagickでImageMagickをアンインストールします
  4. brew updateで自作を更新する
  5. brew install imagemagickで最新の自作をインストールします
  6. brew doctorを実行し、make installで手順4が失敗した場合に、リストされている* .laファイルと* .aファイルのいずれかを削除します。
46
Callmeed

Xcodeをインストールしましたが、macportsに問題がありました。バマー!

Libclparser.dylibファイルを10.6の古いバックアップからコピーし、そのフォルダー内の他のファイルと一致するようにアクセス許可を変更しましたが、機能しました。

こちらもご覧ください: https://stackoverflow.com/questions/6674666/installing-imagemagick-leads-to-weird-error-involveing-opencl

編集:

私はこれを見つけました、それは役に立つかもしれません: http://cactuslab.com/imagemagick/
また、ファイルはここにあります: http://www.workdreamer.com/uploads/libclparser.dylib

5
Rimian

同じエラーが発生し、問題を解決したのは次のとおりです。

  1. MacAppstoreから最新のXCodeバージョンをインストールします
  2. MacportsSudo port install imagemagick)を使用してImageMagickをインストールします

どちらの手順にもしばらく時間がかかりましたが、最終的にImageMagickは再び正常に機能しました。

5

Macportsの代わりにbrewを使用しても再インストールしてもうまくいきませんでした。それをコピーしました。

0
Moritz

次のコマンドを試してください。

brew doctor

一般的な問題を診断します。

その1つは、〜/ .profileからDYLD_FALLBACK_LIBRARY_PATH変数を削除することです。

または、次の方法でlibtoolを再インストールする必要があります。

brew reinstall libtool --universal && brew unlink libtool && brew link libtool
0
kenorb