webdevqa.jp.net

Mac OSにlibssl-dev、libffi-devをインストールする方法?

libssl-devlibffi-devapt-get install libssl-dev libffi-devコマンドでUbuntuにインストールできますが、Macにはインストールできません。コマンドbrew install libssl-dev libffiを使用しようとしましたが、動作しません。

これをインストールするために自作をさせるために何をする必要がありますか?

17
Jackie

これらの特定のパッケージは、MacPortsとHomebrewの両方でこれらの名前の下には存在しません - したがって、あなたが受けているエラーです。 OS Xにこれらの特定のパッケージをインストールするために、あなたはopensslを使いたいでしょう。次のコマンドが役に立ちます。

brew install openssl

opensslが既にインストールされている場合は、それを修復するために以下を実行してみてください。 Stack Overflow で何人かのユーザがDjangoを動かそうとするときの修正としてこれを報告しました。

brew unlink openssl && brew link openssl --force
17
Simon Sheehan

私は Crystal をMacOS Mojaveで起動しようとしていましたが、同様の問題に遭遇しました。

これは私が見ていたエラーメッセージです。

Error: execution of command failed with code: 1: `cc "${@}" -o '/Users/mymbp/.cache/crystal/crystal-run-server.tmp'  -rdynamic  
`command -v pkg-config > /dev/null && pkg-config --libs --silence-errors libssl || printf %s '-lssl -lcrypto'` `command -v pkg-config > /dev/null && pkg-config --libs
 --silence-errors libcrypto || printf %s '-lcrypto'` -lz -lpcre -lgc -lpthread 
/usr/local/Cellar/crystal/0.27.0/src/ext/libcrystal.a -levent -liconv -ldl -
L/usr/lib -L/usr/local/lib`

検索/ usr/local/liblibsslの記述がないことに気づきました。

だから私はシンボリックリンクを追加し、それはそれを修正するようだ。

ln -s /usr/local/Cellar/openssl/1.0.2p/lib/libssl.dylib /usr/local/lib/

注意:Brew Dropが開発したopensslの現在のバージョンは1.0.2pです。あなたのバージョンは違うかもしれません。

7
kroolk