webdevqa.jp.net

Mac OS X Lion用の "make"プログラムはどこにありますか?

私のコンピュータをMac OS X Lionにアップグレードして端末に移動し、「make」と入力しただけです。-bash:make:コマンドが見つかりません

"make"コマンドはどこに行きましたか?

222
Roman Kagan

Xcodeと開発者ツールをインストールしましたか? makeは、gccやその仲間とともに、それ以前にはインストールされていないと思います。 Lion用Xcode 4.1は無料です。

50
CajunLuke

あなたは App Store からXcodeをインストールする必要があります。

次にXcodeを起動し、Xcode->Preferences->Downloadsに移動して「Command Line Tools」という名前のコンポーネントをインストールします。その後、すべての関連ツールが/ usr/binフォルダーに配置され、10.6と同じように使用できるようになります。

533
Tarmo

Apple Developersのダウンロード からXcodeを入手しなくてもコマンドラインツールをインストールできるようです。 Appleアカウントでログインする必要がありました。

あるいは、いったんApp StoreからXcodeをインストールすると、コマンドラインツールがデフォルトでインストールされないことに気付くかもしれません。 Xcodeを開いて設定を開き、「ダウンロード」タブをクリックしてください。そこからコマンドラインツールをダウンロードしてインストールできます。

30
Nick White

Xcode 4.3.2はデフォルトでは「コマンドラインツール」をインストールしませんでした。 Xcode Preferences/Downloads/Componentsタブを開く必要がありました。それぞれの横に「インストール」ボタンがあるオプションのコンポーネントのリストがありました。これには、「コマンドラインツール」と、古いバージョンのiOS用の開発をサポートするためのコンポーネントが含まれています。

これで "make"が利用可能になり、ターミナルを開いて次のように入力して確認できます。make -v

結果は次のようになります。GNU Make 3.81

コマンドラインでcpan -iを使用してPerlモジュールをインストールするPerl開発者など、Xcodeが不要な場合でも、 "make"が必要な場合があります。

21
Able Mac

Xcode 5.1では、環境設定セクションにコマンドラインツールが表示されなくなりました。 https://developer.Apple.com/downloads/index.action に移動して、ご使用のOS Xリリース用のコマンドラインツールのバージョンを選択します。インストーラはそれらを/ usr/binに入れます。

4
fourthchakra

XcodeをインストールしてMountain Lionにアップグレードした場合、または最新のコマンドラインツールがインストールされていない場合、あるいはzshまたは他のシェルがある場合は、developerディレクトリのいくつかの組み込みツールにショートカットできます。

xcrun make
3

NDKを使用してMountain Lionにアップグレードした後、次のエラーが発生しました。

'make'プログラムが見つかりません。 Cygwin make packageをインストールするか、それを指すようにGNUMAKE変数を定義してください。

最新のNDKをダウンロードして使用することでエラーを修正しました

3
Andy

あなたが作る必要があるのは友達だけです。アップルが提供するコマンドラインツールをインストールしてみてください。 (あなたがiOSの開発をしていないと仮定します。)

2
Gaurav Agarwal

Apple Developersのダウンロード サイトから入手可能なさまざまなOSXバージョン用のコマンドラインツールのビルドがあります。ご使用のOSのバージョンの最新リリースを必ず入手してください。

0