webdevqa.jp.net

OSX Mavericksにアップグレードした後:「バージョン1.6に一致するJVMが見つかりません」

今週末、仕事用ノートブックをMountain Lion(10.8.5)からMavericks(10.9.4)にアップグレードした後、ターミナルを開くたびに、次のエラーメッセージが表示されます。

Unable to find any JVMs matching version "1.6"

Java 6がインストールされていませんが、シェルセッションの開始時に実行される一部のツールはそれに依存する必要があります。

この問題の原因をどのように見つけることができますか?トラブルシューティングについてさらに情報を提供できるかどうか教えてください。

4
reinhard.codes

Mac OSX Mavericksインストーラーは、以前にインストールされたバージョンのJavaを削除します。おそらく、.bash_profileファイルにJava 6など)への参照があります。これは、ターミナルの起動時のメッセージを説明します。

Java(from Java 7)の最新バージョンはOracleによって直接サポートされています(Java.comでインストール手順を見つけることができます: どうすればよいですか?インストールJava )。

以前のバージョン(Java 6を含む)はAppleによってサポートされています。 Java 6をインストールする場合は、 Java for OS X 2014-001パッチ をApple Webサイトから直接ダウンロードしてください。

注:これに関するJavaおよびMacOS Xの互換性)に関する有用な情報を見つけることができます Java FAQ

6
ssssteffff