webdevqa.jp.net

Mavenプラグインの問題を解決する:「Mojoをロードできません」

Mavenを使用してpom.xmlのすべての依存関係を構成しました。コマンドmvn installを実行すると、次のエラーが発生します。

[情報]ゴール 'org.Apache.maven.plugins:maven-surefire-plugin:2.4.3:test'を実行するプラグインマネージャーの内部エラー:モジョ 'org.Apache.maven.plugins:maven-surefireをロードできませんプラグイン「org.Apache.maven.plugins:maven-surefire-plugin」の-plugin:2.4.3:test。必要なクラスがありません:org/Apache/maven/surefire/util/NestedCheckedException org.Apache.maven.surefire.util.NestedCheckedException

この問題を解決するにはどうすればよいですか?

18
kiara

この問題が発生しているようです: SUREFIRE-85

最も可能性の高い原因は、ローカルリポジトリ内の破損したjarファイルであると思われます。ローカルリポジトリからすべてのmaven jarを消去してみてください。 <your-home-directory>/.m2/repository/org/Apache/mavenからすべてを削除して、ビルドを再度実行します。

また、Mavenの安定した最新バージョンを使用していることを確認してください。

24
joelittlejohn

私はこの問題を抱えていましたが、組織ディレクトリを削除して再構築することで問題は解決しました。

2
Lyndon

Mavenプロジェクト(Java)をビルドすると「unable to exe mojo」エラーが発生しました。batch_profileに追加したJava_HOMEパスを取得できず、手動でエクスポートしましたJavaホームの問題多くの場合、このビルドの問題が発生する可能性があるように見えますが、システムの環境変数を確認すると役立つ場合があります... David

1
user6000779

Pom.xmlのプラグインバージョンのアップグレードを解決しました1.17 failed 1.30.1 OK

0
PbxMan
Using: Maven 3.0.5 required surefire:>2.10. 2.10 failed:
[ERROR] Failed to execute goal org.Apache.maven.plugins:maven-surefire-plugin:2.10:test (default-test) on project robot-arm: Execution default-test of goal org.Apache.maven.plugins:maven-surefire-plugin:2.10:test failed: A required class was missing while executing org.Apache.maven.plugins:maven-surefire-plugin:2.10:test: org/Apache/maven/surefire/util/NestedCheckedException

2.11は機能します。 2.17は機能します。

0
Kevin Mayfield