webdevqa.jp.net

Ruby on Rails for Mac OSX 10.6の場合)にmysql2 gemをインストールする

Mysql2 gemのインストールに問題があります。

これはgem install mysql2

Marks-MacBook-Pro:~ Mark$ gem install mysql2
Building native extensions.  This could take a while...
ERROR:  Error installing mysql2:
ERROR: Failed to build gem native extension.

/Users/useruser/.rvm/rubies/Ruby-1.9.2-p136/bin/Ruby extconf.rb
checking for rb_thread_blocking_region()... yes
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lm... yes
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lz... yes
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lsocket... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lnsl... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lmygcc... no
checking for mysql_query() in -lmysqlclient... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --Ruby=/Users/useruser/.rvm/rubies/Ruby-1.9.2-p136/bin/Ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib


Gem files will remain installed in /Users/useruser/.rvm/gems/Ruby-1.9.2-p136/gems/mysql2-0.2.6 for inspection.
Results logged to /Users/useruser/.rvm/gems/Ruby-1.9.2-p136/gems/mysql2-0.2.6/ext/mysql2/gem_make.out

また、Rails serverこれが表示されます:

Could not find gem 'mysql2 (>= 0, runtime)' in any of the gem sources listed in your Gemfile.
29
Maze

MySQLライブラリが見つからないようです。 MySQLをインストールしましたか?
homebrew からインストールしてみてください:

brew install mysql

または、macportsやfinkなどの好きなものを使ってインストールしてから、次のコマンドでもう一度試してください。

gem install mysql2
50
ALoR

このコマンドは私にとってうまくいきました:

gem install mysql2 -- --srcdir=/usr/local/mysql/include
38
Sushma Satish

次のコマンドは私のためにうまくいきました。

x.x.x =インストールするmysql2のバージョン。

gem install mysql2 -v 'x.x.x' -- --srcdir=/usr/local/mysql/include
23
Aamir

MySQLがVagrant boxにインストールされているので、Mac OS XではMySQLは必要ありません。したがって、mysql-connector-cをインストールしました。

brew install mysql-connector-c
gem install mysql2
17
Igor Shubovych

homebrewを使用してmysqlをインストールした場合、brew install mysql、これは私にとってうまくいきました:

gem install mysql2 -v 'x.x.x' -- --with-mysql-config=/usr/local/Cellar/mysql/y.y.y/bin/mysql_config

x.x.x =インストールするmysql2 gemのバージョン
y.y.y =インストールしたmysqlのバージョンls /usr/local/Cellar/mysqlで見つけてください。

mysqlのバージョンを取得する

brew info mysql                                                                                                                                                                                                     
mysql: stable 5.7.19 (bottled)
               ...
/usr/local/Cellar/mysql/5.7.19 (322 files, 233MB) *

               ...

バンドルでインストールする場合:

bundle config build.mysql --with-mysql-config=/usr/local/Cellar/mysql/y.y.y/bin/mysql_config
4
aruanoc

以下は私のために働きました

brew install mysql 
brew install mysql-connector-c
gem install mysql2
4
Mayank Jain

Mac OSX 10.6の64ビットアーキテクチャにこのgemをインストールするには、いくつかの追加の環境変数を指定する必要があります。

env ARCHFLAGS="-Arch x86_64" gem install mysql2

Rvmを使用している場合は、これを〜/ .rvmrcファイルのデフォルトオプションとして追加できます。

rvm_archflags="-Arch x86_64"
3
Pan Thomakos

Mysql2をインストールしようとすると、まったく同じ問題とエラーが発生しました。 MySQLのmampインストールは問題なく動作し、それを機能させるためのパスをいじくりまわすのに数時間を費やしましたが、成功しませんでした。

最後に、ALoRからこの投稿に出会い、homebrewを介して新しいバージョンをインストールしました。ただし、homebrewからのすべての指示に従ってください。私はいくつかのステップを逃し、その問題を追跡するためにさらに1時間を無駄にしました-ここにそれらの指示があります: https://stackoverflow.com/a/11061487/1241271

MySQLが正常にインストールされた後、次を実行しました:Sudo gem install mysql2そしてそれは魅力のように働きました。

これが誰かがドキュメントを読むことを怠ったために数時間を無駄にするのを助けることを願っています(newbの間違い)。

1
yellowaj

私はこれが何度も答えられたことを知っていますが、ここで私のために働いているものがあります:May 20、2019 OSX Mojave 10.14.4 MySQL Ver 14.14 Distrib 5.7.24、for osx10.14(x86_64)using EditLine wrapper Ruby 2.5.0p0(2017-12-25リビジョン61468)[x86_64-darwin17] Rails 5.2.1

export LIBRARY_PATH=$LIBRARY_PATH:/usr/local/opt/openssl/lib/
gem install mysql2 -- --with-mysql-config=/usr/local/Cellar/mysql\@5.7/5.7.24/bin/mysql_config

「/usr/local/Cellar/[email protected]/5.7.24/bin/mysql_config」を「/ usr/local/Cellar/mysql」からの現在の有効なパスに変更します

お役に立てれば!

0

OpensslがHomebrewを介してMacにインストールされていることを確認します。

brew install openssl

Install mysql2 gem.

gem install mysql2 -v '0.5.2' -- --with-ldflags=-L/usr/local/opt/openssl/lib --with-cppflags=-I/usr/local/opt/openssl/i
0
BMA88

Catalina(10.15.x)にアップグレードした後、同じ問題が発生しました

私のGemfile.lockでmysql2-0.3.20が定義されていますが、インストールできませんでした。しかし、mysql2-0.5.2にアップグレードしたとき、それは機能しました

gem update mysql2 -- --srcdir=/usr/local/include/mysql/

Mysqlがbrewでインストールされていることを確認してください。

brew install mysql
brew link mysql                                                                                                               

(/usr/local/Cellar/mysql/8.0.18をリンクしています... 95個のシンボリックリンクが作成されています)

ただし、この後、gem mysql2がインストールされましたが、バンドル更新mysql2が機能しませんでした。

しかし、この他の答えは私を助けました https://stackoverflow.com/a/39628463/110214

bundle config --local build.mysql2 "--with-ldflags=-L/usr/local/opt/openssl/lib --with-cppflags=-I/usr/local/opt/openssl/include"

bundle update mysql2