webdevqa.jp.net

「npm update -g」の後のエラー「モジュール 'npmlog'が見つかりません」

NVM 0.30.1があり、それを使用してFedora 22にnode.js v5.4.0(NPM 3.5.4)をインストールしました。npm update -gを実行すると、次の警告が表示されます。

npm WARN EBUNDLEOVERRIDE Replacing bundled npm > init-package-json with new installed version
npm WARN EBUNDLEOVERRIDE Replacing bundled npm > node-gyp with new installed version
npm WARN EBUNDLEOVERRIDE Replacing bundled npm > npm-install-checks with new installed version
npm WARN EBUNDLEOVERRIDE Replacing bundled npm > npmlog with new installed version
npm WARN EBUNDLEOVERRIDE Replacing bundled npm > read-package-json with new installed version

その後、npmを実行すると、次のエラーが表示されます。

module.js:328
    throw err;
    ^

Error: Cannot find module 'npmlog'
    at Function.Module._resolveFilename (module.js:326:15)
    at Function.Module._load (module.js:277:25)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)
    at /home/peflorencio/.nvm/versions/node/v5.4.0/lib/node_modules/npm/bin/npm-cli.js:20:13
    at Object.<anonymous> (/home/peflorencio/.nvm/versions/node/v5.4.0/lib/node_modules/npm/bin/npm-cli.js:76:3)
    at Module._compile (module.js:398:26)
    at Object.Module._extensions..js (module.js:405:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)

誰がそれが何であり、それを解決する方法を知っていますか?

ありがとう

19
peflorencio

答えてくれてありがとう。これは バグ で、Node v5.4.1ですでに修正されています。現在は通常どおり動作しています。

7
peflorencio

私にとってこれを修正したのは

Sudo rm -rf /usr/local/lib/node_modules/

次に、ノードを再インストールします(npmを使用)。

6
Alan H.

npm update -gは、npmを最新バージョンに更新できません。 npmインストールを手動で更新することで問題を解決します。

  1. ノードをインストール/再インストールして、バンドルされたnpmを取得します
  2. 実行npm install -g [email protected]グローバルnpmインストールを更新する
  3. npm update -g動作するはずです
4
motou

Windows 10 PCでも同じ問題に直面しました。解決策を検討した後、私が直面している問題の正確な解決策を見つけることができなかったため、モジュール「npmlog」が見つかりませんノードjsをアンインストールしました次に、「C:\ Users\YourPCName\AppData\Roaming」の「npm」と「npm-cache」の両方を削除しました

次に、 Node JS Website からノードの最新バージョンをダウンロードしました

そして、インストールされたノードjs

その後、環境変数のパスを確認しました。

最後にコマンドプロンプト「管理者として実行」を実行し、npm install npm -g

バージョンを確認すると、最新バージョンが表示されます。 「npm -v」

最新バージョン-v3.10.9を入手しました

これを試して。これは動作するはずです。

3
Saiyaff Farouk

Linuxを使用している人が問題に直面している場合の解決策は次のとおりです。

この投稿の日付の時点で、Nodejsでパッケージ化されたNPMバージョンは機能しません。このパッケージをインストールした場合は、実行します

Sudo rm -rf /usr/local/bin/npm
Sudo apt-get install node
Sudo mv /usr/bin/npm /usr/local/bin/npm

新しいバージョンは3.10.8で、古いエラーはなくなっているはずです

2
hithere

init-package-json、node-gyp、npm-install-checks、npmlog、read-package-jsonが正しくインストールされませんでした。理由はわかりませんが。

問題の根本原因は見つかりませんでしたが、今のところ上記のパッケージをハッキングする方法でインストールしました。

  • Npmが更新されなかった以前のノードバージョンにロールバックします。たとえば、nvm use iojs
  • cdをnpmがインストールされた場所、たとえばcd /home/peflorencio/.nvm/versions/node/v5.4.0/lib/node_modules/npmに追加し、rm -rf node_modules/init-package-json && npm install init-package-jsonなどのパッケージを再インストールします。
1
Yujun Wu

いくつかの答えはすでに質問に答えていましたが、私はまだ自分の考えを投げ込みたいです。そのコードを実行した後にnpm update -g npmを実行するように言われた後、同じ問題が発生し、エラーが発生しました。 Node Version Manager(nvm)を使用して解決しました:

nvm install 8

注:実際には8ではなく、選択したバージョン(例:(6,5))。バージョン番号を書き込むと、指定されたバージョンの安定版が自動的にインストールされます。インストール後、CLIメッセージが表示されます:

Now using node v8.11.4 (npm v5.6.0) 
0
Fillipo Sniper