webdevqa.jp.net

モジュール 'internal / util / types'が見つかりません

私のウィンドウで既存のnodejsプロジェクトをセットアップしようとしています

Npm -v :- 6.0.1
node -v :- v8.11.1

ノードapp.jsを実行すると、次のエラーが発生します

include-allは(C:\ xampp\htdocs\sails\backend\api\services\FileUploadService.js)を要求しようとしましたが、エラーが発生しました::詳細:エラー:Functionでモジュール 'internal/util/types'が見つかりません.Module._resolveFilename(module.js:547:15)at Function.Module._load(module.js:474:25)at Module.require(module.js:596:17)at require(internal/module.js: 11:18)at evalmachine.:31:26 at Object (C:\ xampp\htdocs\sails\backend\node_modules\s3\node_modules\graceful-fs\fs.js:11:1)Object.Module._extensionsのModule._compile(module.js:652:30) Module.load(module.js:565:32)at tryModuleLoad(module.js:505:12)at Function.Module._load(module.js:497:3)の.js(module.js:663:10) Module.require(module.js:596:17)at require(internal/module.js:11:18)at Object (C:\ xampp\htdocs\sails\backend\node_modules\s3\node_modules\graceful-fs\graceful-fs.js:3:27)Object.ModuleのModule._compile(module.js:652:30) _extensions..js(module.js:663:10)at Module.load(module.js:565:32)at tryModuleLoad(module.js:505:12)at Function.Module._load(module.js:497: 3)Objectのrequire(internal/module.js:11:18)のModule.require(module.js:596:17)で(C:\ xampp\htdocs\sails\backend\node_modules\s3\lib\index.js:3:10)

何か案が?私が欠けているもの

8
Hitu Bansal

同じ問題がありました。それを調査した後、人々がこの問題を修正した多くの方法があるように見えます。

私にとって問題の原因は、ノードをアップグレードし、プロジェクトを再構築する必要があることでした。

npm再構築

私のためにそれを修正しました。

ここで長い議論があります: nodemon

3
Vlad

以前のバージョンに戻し、npmを実行するたびに発生していたクラッシュを解決しました。

Sudo n 6.12.0

おかげで: https://github.com/remy/nodemon/issues/1124#issuecomment-345181229

2
Gene Bo