webdevqa.jp.net

以前のバージョンのパッケージをインストールする

Nvmを使用してノードv0.4.10をダウンロードし、そのバージョンのノードで動作するようにnpmをインストールしました。 

Express usingを使おうとしています 

npm install express -g

そして、expressはnode version> = 0.5.0を必要とするというエラーを受け取ります。 

まあ、これは奇妙なことです、なぜなら私はnode + express + mongodb tutorial ここ node v0.4.10を使ったという指示に従っているからです。私の仮定が正しい場合、どのように私は私のセットアップで動作するであろうバージョンを取得するようにnpmに言うのですか?

729
stewart99

古いバージョンのパッケージをインストールする必要がある場合は、それを指定するだけです。

npm install <package>@<version>

例えば、次のとおりです。npm install [email protected]

そのコマンドに--saveフラグを追加してpackage.jsonの依存関係に追加することも、正確なバージョンをpackage.jsonの依存関係で指定したい場合は--save --save-exactフラグも追加できます。

installコマンドはここに文書化されています: https://docs.npmjs.com/cli/install

利用可能なパッケージのバージョンがわからない場合は、次のものを使用できます。

npm view <package> versions

そしてnpm viewはパッケージに関する他のことを見るためにも使うことができます。 https://docs.npmjs.com/cli/view

1296
Bret Copeland

とても簡単です。例えばこう書いてください。

npm install -g [email protected]

または

npm install -g [email protected]    // For the last stable version
npm install -g [email protected]      // For the most recent release
77
inaps

最初に古いバージョンを削除してから 文字通り 以下を実行してください。

npm install [email protected]
65

私の意見ではそれが最も簡単で最速の方法です:

$ npm -v

4.2.0 

$ npm install -g [email protected]

...

$ npm -v

3.10.10 

40

npm install -g npm @ version

ダウングレードしたい場所

npm install -g [email protected] 

1
Lakshay Sharma

このタイプの問題を解決する一般的な方法があります。これは、特にリポジトリをクローンしてローカルで実行する場合にも役立ちますが、バージョンの分析が少し必要です。

パッケージnpm-check-updatesを使用して、図( https:// www。 npmjs.com/package/npm-check-updates ):

enter image description here

この情報を使用して、さまざまなパッケージの更新ステータスを確認し、アップグレード/デグレードするパッケージとアップグレードしないパッケージを決定できます。

リストにあるすべてのパッケージを更新することにしたと仮定すると、package.jsonファイルのみを変更するncu -uコマンドを使用できます。 npm installを実行して、インストール済みのパッケージとpackage-lock.jsonを更新します。

次に、リポジトリの要件に応じて、必要なものを調整し、特定のバージョンをnpm view <package> versionsおよびnpm install <package>@<version>でインストールします

1

このコマンドを使用してnpmパッケージを更新できます。

npm install <package_name>@<version_number>

例: npm install [email protected]

0
Mehedi Abdullah

次のコマンドを使用して、以前のバージョンのnpmパッケージをインストールできます。

npm install [email protected]
0
Pinky