webdevqa.jp.net

nvmでノードバージョンを変更する方法

gulpを使用しようとすると、yeomanを使用してcmdを実行しようとすると、gulp serveというエラーが表示され、インストールしたことを認識して、古いバージョンのノード(8.9.4)が必要であることがわかります最新バージョン(10.14.1)。

だから私はnvmをインストールしてノードのバージョンを変更し、それをパスC:\に設定する必要があり、その後成功して実行しました:nvm install 8.9.4そしてそれを使用しようとすると:nvm use 8.9.4、その常に使用されている最新バージョン

enter image description here

8.10.0を使用しようとすると、node -vを実行し、アクセスが拒否されたことを通知します。これは他のノードコマンドと同じです

7
Billy DEKAR

あなたが使用する必要があります

nvm use 8.10.0

このコマンドを管理者として実行する必要があることに注意してください