webdevqa.jp.net

NVMを使用してデフォルトのノードバージョンを設定するにはどうすればよいですか?

2つのノードバージョン:v6.11.5およびv9.0.0でnvm(zsh Shellを使用するubuntu)をインストールしました。nvmのデフォルトバージョンはv9.0.0です。

ノードのバージョンを変更する必要があるたびに

$ nvm list
         v6.11.5
->       v9.0.0
         system
default -> node (-> v9.0.0)
node -> stable (-> v9.0.0) (default)
stable -> 9.0 (-> v9.0.0) (default)


$ nvm v6

Nvmバージョンのデフォルトを変更してv6.11.5を定義するにはどうすればよいですか?

55
Pablo Ezequiel

(nvmメンテナはこちら)

nvm alias default 6.11.5は、特定のバージョンに固定する場合に使用します。

nvm alias default 6を実行することもできます。

いずれにしても、nvmの最新バージョンにアップグレードする必要があります(この記事の執筆時点ではv0.33.11)

98
LJHarb