webdevqa.jp.net

ヤーンがnvmバージョンノードバージョンにインストールされていません

ノードのnvmバージョンを変更すると、yarnで問題が発生します。 〜/ .nvmフォルダーを確認すると、2つのノードバージョンが表示されています。

  • v8.11.0
  • v8.11.3。

糸をグローバルにインストールしました。 using npm install -g yarn v8.11.0を使用していたとき。

糸が見える

.nvm/versions/node/v8.11.0

しかし、nvm v8.11.3に切り替えるか、nvmエイリアスのデフォルトをv8.11.3に設定すると
糸は使用できなくなりました。 v8.11.3フォルダーに追加することを期待して、再度グローバルインストールを試みましたが、v8.11.0に追加しようとし続けます

フォルダーv8.11.0も削除しましたが、npm install -g yarnを実行するとそれが再作成されます

Nvmのノードバージョンスイッチを使用してyarnを使用できるようにインストールする方法

8
me-me

Nvmを使用して新しいノードバージョンをインストールし、npmを使用してyarnをインストールする場合、新しいノードバージョンのyarnを再インストールする必要があります。

試してください:

nvm install 8.11.3
nvm use 8.11.3
npm install -g yarn

これにより、糸がインストールされます。

.nvm/versions/node/v8.11.3/

その後、8.11.0と8.11.3を切り替えても、糸は機能します。

16
TMT

~/.npmrcファイルがあるかどうかを確認します。

その場合は、その中のコンテンツを削除します。

3
bellemere

最近、この問題に遭遇しました(Macで)。私は使わなければなりませんでした

brew install yarn --ignore-dependencies

そしてそれは私のためにそれをしました。ヤーンは、nvmで切り替えたノードバージョンに関係なく使用できます。これが誰かの助けになることを願っています。詳細については、こちらをご覧ください: https://yarnpkg.com/lang/en/docs/install/#mac-stable

0
doubleya