webdevqa.jp.net

MySQL64ビットを使用したSnowLeopard上のmysql-python

私の人生の間、mysql-pythonをSnowLeopardで動作させることができないようです。

現在、Snow Leopard(python 2.6.1)に同梱されているデフォルトバージョンのpython)を使用しています。MySQL 5.1.45 x86_64をインストールしました。

Mysql-python http://sourceforge.net/projects/mysql-python/ のソースをダウンロードし、次のコマンドでコンパイルします。

tar xzf MySQL-python-1.2.3c1.tar.gz
cd MySQL-python-1.2.3c1
ARCHFLAGS='-Arch x86_64' python setup.py build
ARCHFLAGS='-Arch x86_64' python setup.py install

また、インポートしようとすると、次のエラーが発生します。

Python 2.6.1 (r261:67515, Jul  7 2009, 23:51:51) 
[GCC 4.2.1 (Apple Inc. build 5646)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import MySQLdb
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "build/bdist.macosx-10.6-universal/Egg/MySQLdb/__init__.py", line 19, in <module>

  File "build/bdist.macosx-10.6-universal/Egg/_mysql.py", line 7, in <module>
  File "build/bdist.macosx-10.6-universal/Egg/_mysql.py", line 6, in __bootstrap__
ImportError: dlopen(/Users/derek/.python-eggs/MySQL_python-1.2.3c1-py2.6-macosx-10.6-universal.Egg-tmp/_mysql.so, 2): no suitable image found.  Did find:
/Users/derek/.python-eggs/MySQL_python-1.2.3c1-py2.6-macosx-10.6-universal.Egg-tmp/_mysql.so: mach-o, but wrong architecture

何か案は?または、最初からやり直すのに最適なルート。

3
Derek Reynolds

私もこの問題に遭遇し、解決策を見つけられませんでした。後でMySQL32ビットに変更され、MySQL-Pythonが正常にインストールされ、問題が解決されました〜

2
ufengzh

すでにインストールされているファイルを削除してから、次のコマンドでインストールしてみてください。

Sudo easy_install-2.6 mysql-python

1
Studer

macport で試しましたか?

Sudo port install py26-mysql
0
user46046