webdevqa.jp.net

PHP警告:PHPスタートアップ:????????:モジュールを初期化できません

Phpを5.1から5.2.10にアップグレードした後、php -v

    # php -v
    PHP Warning:  PHP Startup: fileinfo: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP Warning:  PHP Startup: mcrypt: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP Warning:  PHP Startup: memcache: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP Warning:  PHP Startup: mhash: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP Warning:  PHP Startup: mssql: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP Warning:  PHP Startup: readline: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP Warning:  PHP Startup: tidy: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP 5.2.10 (cli) (built: Nov 13 2009 11:24:03)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

どうすれば修正できますか?ありがとう!

15
ohho

peclコマンドを使用してこれらの各モジュールをアップグレードしてください

# pecl upgrade fileinfo
# pecl upgrade memcache
# pecl upgrade mhash
# pecl upgrade readline

等...

11
Murdani Eko

初期化できないモジュールを消去し、再インストールします。

2
kirisky

これは、PHPの新しいバージョンをインストールしようとしたときに起こりました。また、そのためにApacheを再構成する必要があることに気付いた後、古いPHPバージョンに切り替えました。ここで私のために働いた解決策:

httpd.confを正しいバージョンに変更します。

 PHPIniDir ...
 LoadModule php5_module ...

変更された

PATH - Environment Variable

効果がない場合

rename or delete the new PHP(-Version)-Folder

なんらかの理由で、最後のステップは私のためにトリックを行いました。再起動後でも、これを行う前に効果がありませんでした。

0
hogan

私の場合、Windows Server 2008では、PATH変数を変更する必要がありました。以前のバージョンのPHP(VC9)はその中にありました。

PHP(VC11)の新しいバージョンで変更しました。

Apacheの再起動後、大丈夫でした。

0
kmas

これは、誰かがそれが役立つと思う場合にこの問題が発生した理由を説明しているだけです。

私の問題は、homebrewでphpをアップグレードし、ある時点でプロファイルまたはbashrcファイルの変数PHP_INI_SCAN_DIRを強制して、古いphpバージョンを指していることでした。その行を削除して修正しました。

0
pcambra

Homebrewでphpをインストールした場合、Apache2.confファイルがphp5.soファイルのhomebrewバージョンを使用しているかどうかを確認します。

0
Pauls Bebris

これは古いスレッドですが、同様の問題を解決しようとしたときに偶然見つけました。

私にとっては、php_wincache.dll。 WindowsサーバーでPHP 5.5.38から5.6.31に更新中です。何らかの理由で、DLLファイルが更新されていませんほとんどはそうでしたが、一部はそうではありませんでした。

したがって、これと同様のエラーが発生した場合は、すべての拡張機能が適切に配置され、更新されていることを確認してください

0
cfnerd