webdevqa.jp.net

なぜWordPressは時代遅れのjQuery v1.12.4を使うのですか?

ソースコードをチェックしながら、私はWordPressがjQuery v1.12.4を使用しているのを見ました。 WordPressがこの古いバージョンのjQueryを使用するのはなぜですか?

23
Sandun

WP coreによってロードされるjQueryを使用したテーマやプラグインは数多くあります。 jQueryが更新されるたびに、古いテーマとプラグインが壊れる危険性があります(それらの多くはまだ使用されていますが、もはや更新されていないため)。ソースコードにjquery-migrate.jsも表示されるのはそのためです。これは、プラグイン/テーマで使用されていた古い関数をキャッチし、それらが新しいバージョンのjQueryでも動作することを確認するスクリプトです。

JQueryの3.xファミリに移行すると、多くのプラグインやテーマが壊れることになります。これは、廃止予定のすべての項目に対して 移行スクリプトを作成することは不可能 です。これが、1.xおよび2.xファミリーが既に存在している間に、3.xファミリーの新しいバージョンがまだ開発されていた理由です。 (セキュリティ)パッチを除いて、1.x2.xの後には、{ 新しい1.122.2のバージョンはありません があります。 jQueryの1.12は現在古くなっていませんが、近い将来になるでしょう。

だから、WordPressはバインドされています。それがより高いjQueryバージョンにアップグレードしないなら、それは新しい可能性に追いつくことができません。ただし、アップグレードした場合、古いサイトは壊れます。最も可能性の高い結果はWPが数年間待つことになるので、古いテーマ/プラグインはいずれにせよ段階的に廃止され、そして 3.xファミリーへジャンプ です。

説明

上記のことから、1.xバージョンから3.xへの移行は実際には不可能であることが示唆されるかもしれません。それは真実ではない。ちょっと複雑です。トリックは、最初に1.12にアップグレードし、古い移行スクリプトを使用して結果をデバッグしてから、3.0で動作する1.12移行スクリプトを追加することです。詳しい説明 ここ

31
cjbj
  • それは - 時代遅れではない
  • 2.xや3.xに移行するのは時期尚早です、人々はまだ1.xでのみサポートされているIE8を使用します
24
Nabil Kadimi

もっと正確に。

1.xブランチにはIE 6/7/8のサポートが含まれていますが、2.xブランチには含まれていません。

https://blog.jquery.com/2016/05/20/jquery-1-12-4-and-2-2-4-released/ /

0
prosti