webdevqa.jp.net

AttributeError:モジュールPipには属性 'main'がありません

Zulipと呼ばれるオープンソースプロジェクトのpython apiをビルドしようとしていますが、下のスクリーンショットに示されているのと同じ問題が発生し続けています。

私はpython3を実行しています。私のpipバージョンは10.0.0です。問題のファイルはsetup.pyで、混乱しているコードはpip.main()属性にアクセスしてパッケージをインストールするときです。

現在、このビルドはオープンソースプロジェクトであるため成功するはずですが、pip.main()に関する依存関係の問題を修正するために何時間も努力しています。

どんな助けも大歓迎です。

enter image description here

49
Kishan Patel
python3 -m pip install --user --upgrade pip==9.0.3

PIPの問題:ロールバック

65
ericson.cepeda

Pipはリファクタリングを行い、メインを内部に移動したようです。それについての包括的な議論がここにあります: https://github.com/pypa/pip/issues/524

私の回避策は変更することでした

import pip
pip.main(...)

from pip._internal import main
main(...)

ディスカッションを読むことをお勧めします。これが最善のアプローチであるかどうかはわかりませんが、私の目的には役立ちました。

26
mdoc-2011

ファーストラン

import pip
pip.__version__

結果が「10.0.0」の場合、pipが正常にインストールされたことを意味します
pip 10.0.0はpip.main()をサポートしなくなったため、これが役立つ場合があります
https://pip.pypa.io/en/latest/user_guide/#using-pip-from-your-program
import subprocess subprocess.check_call(["python", '-m', 'pip', 'install', 'pkg']) # install pkg subprocess.check_call(["python", '-m', 'pip', 'install',"--upgrade", 'pkg']) # upgrade pkgのようなものを使用します


編集:pip 10.0.1はまだメインをサポートしていません
次のコマンドを使用して、pipバージョンをダウングレードすることを選択できます。
python -m pip install --upgrade pip==9.0.3

26
Luke.SWK

これは私を助けます https://pip.pypa.io/en/stable/installing/

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
python get-pip.py

Python3を使用していて、デフォルトに設定していない場合。これを行う、

python3 get-pip.py

わたしにはできる。

5
Evan

pipインストールの問題かどうかを確認するには、easy_installを使用してpipの以前のバージョンをインストールしてみてください。

easy_install pip==9.0.1

これが成功した場合、pipは現在動作しているはずです。次に、必要なpipの他のバージョンをインストールします。

pip install pip==10....

または、バージョン9.0以上のプロジェクトが必要なため、version 9.0.1のままにしておくこともできます。

プロジェクトをもう一度ビルドしてください。

5
Shuwn Yuan Tee

私の解決策は、pipのバージョン番号を確認し、正しいメイン関数を正しくインポートすることです

    import pip

    if int(pip.__version__.split('.')[0])>9:
        from pip._internal import main
    else:
        from pip import main
    def install(package):
        main(['install', package])
3
Adewole Adesola

python -m pip install --upgrade pip==9.0.3が機能せず、Windowsを使用している場合、

  1. このディレクトリに移動し、pipフォルダーを別の場所に移動します。

enter image description here

  1. IDEを開いている場合は閉じます。

  2. Pythonで 'Repair'を押します3。

enter image description here

  1. IDEはpipパッケージの検出を停止し、それらのインストールを促すメッセージが表示されます。自動更新をブロックすることにより、最新の安定したpipバージョンをインストールして保持します。 enter image description here
3
AeFinches

Pip 10.0。*はmainをサポートしていません。

Pip 9.0.3にダウングレードする必要があります。

2
Matthew

このコマンドを試してください。

python -m pip install --user pip==9.0.1
1
Ashfaq Memon

Windowsについてはわかりません。しかし、Macユーザーの場合、これを使用します。

pip install --upgrade pip==9.0.3
0
Adam Liu

ステップ1 curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py Step2 python get-pip.py

0
Kiran

最新バージョンへのアップグレードでこの問題を修正しました

Sudo pip install --upgrade pip

私のバージョン:pip 18.1 /Library/Python/2.7/site-packages/pip(python 2.7)

0
matt

ファイルの編集:108行目のC:\ Users\kpate\hw6\python-zulip-api\zulip_bots\setup.py

rcode = pip.main(['install', '-r', req_path, '--quiet'])

行う

rcode = getattr(pip, '_main', pip.main)(['install', '-r', req_path, '--quiet'])´
0
SleX

Windowsでanaconda3 4.4.0(python 3.6)でpipを使用しているときに、同じエラーに直面しました。

次のコマンドで問題を修正しました。

easy_install pip==18.*  ### installing the latest version pip

または、下位バージョンのpipが必要な場合は、コマンドに同じことを記載してください。

または、次のように下位バージョンをインストールしてから、同じバージョンを最新バージョンにアップグレードしてみてください。

easy_install pip==9.0.1

easy_install --upgrade pip
0
divya gera

私にとって、この問題は、site-packagesフォルダー内でpythonを実行しているときに発生しました。他の場所で実行した場合、問題ではなくなりました。

0
Phylliida

それはうまくいきます:

 py -m pip install --user --upgrade pip==9.0.3
0
i_th