webdevqa.jp.net

CentOSにpipとeasy_installをインストールする方法

CentOSにpipeasy_installをインストールしようとしましたが、見つかりませんでした。

どうすればインストールできますか?

また、Pythonには2つのバージョン、2.4と2.7があります。新しくインストールしたコンポーネントをPython 2.7に確実にリンクするには、どのようにpipを使用しますか?

24
Mirage

簡単でした。 pipのパスは次のとおりです。

/opt/python2.7/bin/pip

ない場合は、次を使用してインストールします。

/opt/python2.7/bin/easy_install pip

そしてそれはそれをインストールします。

13
Mirage

pipインストーラーのドキュメント に続いて、次のコマンドを発行できます。

# install setup tools
curl https://bitbucket.org/pypa/setuptools/downloads/ez_setup.py | python -
# install pip
curl https://bootstrap.pypa.io/get-pip.py | python -
13
pdeschen

以前の回答からeasy_installを取得することができませんでした。他のコマンドに従ってpipをインストールしました。 (Sudo権限が必要)

easy_installをインストールするには:

Sudo yum install python-setuptools python-setuptools-devel

pipをインストールするには:

Sudo easy_install pip

10
ravi.zombie

リポジトリ内のパッケージはすべて2.4用にビルドされます。 2.7のソースからインストールする必要があります。

python2.7 setup.py install

私はCentOS 7でこのコマンドを発行しましたが、うまくいきました

curl https://bootstrap.pypa.io/get-pip.py | python -
5
jeremyforan

アマゾンウェブサービスクライアントツール(awscli)の最新バージョンをインストールしたいと思いました。これはシステムpythonを使用してCentOS 64最小で行われました:最新のsetuptoolsをダウンロードしてください(バージョン1.16は here で見つかります)

Sudo -s
cd /opt
tar xzf <setuptools.tar.gz>
cd setuptools<-1.1.6>
python ez_setup.py
easy_install pip

これで、pipを使用して好きなものをインストールできます。例えば、

pip install awscli

この方法は非常に迅速で、CentOSシステムをPythonに保つことができました。

1
Snap Shot

http://www.cyberciti.biz/faq/debian-ubuntu-centos-rhel-linux-install-pipclient/ EPELリポジトリを使用したRed Hatの方法:

[[email protected] tmp]# wget http://mirror-fpt-telecom.fpt.net/Fedora/epel/6/i386/epel-release-6-8.noarch.rpm
--2013-12-31 13:49:12--  http://mirror-fpt-telecom.fpt.net/Fedora/epel/6/i386/epel-release-6-8.noarch.rpm
Resolving mirror-fpt-telecom.fpt.net... 118.69.250.132
Connecting to mirror-fpt-telecom.fpt.net|118.69.250.132|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14540 (14K) [application/x-redhat-package-manager]
Saving to: “epel-release-6-8.noarch.rpm”

100%[======================================>] 14,540      2.66K/s   in 5.3s    

2013-12-31 13:49:18 (2.66 KB/s) - “epel-release-6-8.noarch.rpm” saved [14540/14540]

[[email protected] tmp]# rpm -ivh epel-release-6-8.noarch.rpm
warning: epel-release-6-8.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
Preparing...                ########################################### [100%]
   1:epel-release           ########################################### [100%]
[[email protected] tmp]# yum install python-pip
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink                                            |  13 kB     00:00     
 * PUIAS_6_core_Base: puias.math.ias.edu
 * PUIAS_6_core_Updates: puias.math.ias.edu
 * base: centos.sonn.com
 * epel: epel.mirror.freedomvoice.com
 * extras: centos.mirror.freedomvoice.com
 * rpmforge: mirror.webnx.com
 * updates: mirrors.tummy.com
epel                                                     | 4.2 kB     00:00     
epel/primary_db                                          | 5.8 MB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-pip.noarch 0:1.3.1-4.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch            Version                Repository     Size
================================================================================
Installing:
 python-pip          noarch          1.3.1-4.el6            epel          330 k

Transaction Summary
================================================================================
Install       1 Package(s)

Total download size: 330 k
Installed size: 1.0 M
Is this ok [y/N]: y
Downloading Packages:
python-pip-1.3.1-4.el6.noarch.rpm                        | 330 kB     00:00     
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
Importing GPG key 0x0608B895:
 Userid : EPEL (6) <[email protected]>
 Package: epel-release-6-8.noarch (installed)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : python-pip-1.3.1-4.el6.noarch                                1/1 
  Verifying  : python-pip-1.3.1-4.el6.noarch                                1/1 

Installed:
  python-pip.noarch 0:1.3.1-4.el6                                               

Complete!

私はfpt.vnにリダイレクトするfpt.netサイトに少し懐疑的でしたが、nixCraftがそれで大丈夫だと言ったら、それらが正しいことを望んでいます。

1
jcomeau_ictx

CentOSにpipをインストールする方法はたくさんあるようですが、私にとってうまくいった方法は your method でした。

Sudo python2.7 /usr/local/bin/easy_install pip

最初に他のいくつかの方法を試しました。私が見つけた最も一般的なものは EPELリポジトリでyumを使用する です。

cd /tmp
wget http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
Sudo rpm -ivh epel-release-5-4.noarch.rpm
Sudo yum -y install python-pip

「パッケージpython-pipがありません」というエラーで、yumのインストールが失敗しました。

Pipプロジェクトのドキュメントget-pip.pyスクリプトですが、それでもエラーが発生しました。

1
Don Kirkby

pip python curlを使用してパッケージマネージャをインストールし、get-pip.py

curl "https://bootstrap.pypa.io/get-pip.py" -o "get-pip.py"
python get-pip.py
0
Jude Job

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

rpm -ivh epel-release-6-8.noarch.rpm

yum -y install python-pip

0
user865586