webdevqa.jp.net

Mac OS X Snow LeopardでNumpyをアップデートする方法は?

Numpyを最新のものに更新するにはどうすればよいですか?ここから.dmgファイルをダウンロードする必要があります:

http://sourceforge.net/projects/numpy/files/

この.dmgは10.5のみですか?これらの手順を使用してnumpyをインストールしました:

http://www.scipy.org/Installing_SciPy/Mac_OS_X

私の現在のNumpyは1.2.1です。 Mac OS X 10.6.1 SnowLeopardで実行しています。ありがとう!

15
larus

Sudo easy_install -U numpy

Setuptoolsを介してインストールすると、システム以外のユーティリティのsys.pathに新しいnumpyが取得されます(一部のAppleユーティリティはsystem-numpyに依存していると言われています)。一般に、setuptoolsはOSXで「正しいことをする」こと。

32
Barry Wark

使用する pip install -U numpy代わりに、easy_installは廃止され、pipが優先されます。

7
RNA

他の場所で提案されているように、macportsは複数のアーキテクチャで正常に動作し、MacOsX +のバージョンではアップデートなどが可能です。

$ port search numpy
py-numpy @1.3.0 (python)
    The core utilities for the scientific library scipy for Python

py25-numpy @1.3.0 (python)
    The core utilities for the scientific library scipy for Python

py25-symeig @1.4 (python, science)
    Symeig - Symmetrical eigenvalue routines for NumPy.

py26-numpy @1.3.0 (python)
    The core utilities for the scientific library scipy for Python

py26-scikits-audiolab @0.10.2 (python, science, audio)
    Audiolab is a python toolbox to read/write audio files from numpy arrays

Found 5 ports.
$

あなたの場合、単に発行します:

$ Sudo port install py26-numpy

または、自分でコンパイルする必要がある場合は、 HJBlog の手順が非常に役立ちます。テストしたところ、64ビットバージョンのmatplotlibを簡単にコンパイルできました。

4
meduz

何らかの理由で、easy_install -Unumpyが機能しませんでした。

print numpy.__version__

常に1.2.1を与えるだろう

それで、私は最初にnumpy 1.2.1を見つけてフォルダー全体を削除することにより、それを削除しました。

import numpy
print numpy.__file__

GNU Fortranコンパイラを以下からダウンロードしました:

http://r.research.att.com/gfortran-4.2.3.dmg

Easy_installを使用してnumpyをインストールしました。

振り返ってみると、Fortranコンパイラーがインストールされていれば、easy_install -Unumpyが機能していた可能性があります。

0