webdevqa.jp.net

Python 3.5をインストールできないXP Professional

Python 3をインストールしようとしていますXP Professional;次の画面が表示されます(インストールボタンがありません):

python install

私の意見では、これは明らかに報告されていないエラー、またはレンダリングの問題です。この問題はどのように軽減されますか?この問題を解決できる場合、それは追加の関連問題の兆候ですか?

12
motoku

インストーラーのバグかもしれませんか? Python 3.4.3- https://www.python.org/ftp/python/3.4.3/python-3.4.3.msi を試してください

または、3.5.0rc3インストーラーの空白をクリックします。

Enter image description here

8
strangeman

悲しいことに、Python過去のバージョン3.4.3のすべてのバージョンは、Windows XPとの互換性がなくなりました。それらはすべて一緒にサポートしなくなりました-.5 Windows XPでのインストールが失敗します

14
Zhukuu

from python.readthedocs.io

PEP 11で指定されているように、PythonリリースはWindowsプラットフォームのみをサポートしていますが、Microsoftは拡張サポートのプラットフォームを検討しています。これは、Python 3.7がWindows Vistaをサポートし、新しい。Windows XPサポートが必要な場合は、インストールしてくださいPython 3.4。

最後のウィンドウXP Python build is 3.4.4: https://www.python.org/downloads/release/python-344 / 3.4.7(2017-08-09)がコードソースとして利用可能

5
jerome

CPython 3.5はXPでは機能しませんが、 PyPy があり、 代替Python実装 が機能します。
ただし、現在のバージョンのPyPy3.5 v6.0 まだasyncio moduleをサポートしていません 、おそらく3.5アップデートの最も興味深い部分です。

2
user

ちょうどこれを見つけた(2019年12月)

誰かがPython 3.4.10 for Windows XPをビルドしました。サードパーティからのものであるため、自己責任で使用してください。

->ダウンロード<-

1
tabdiukov

Pythonダウンロードページ によると、Python 3.5+ cannot be used on Windows XP or earlier.

サポートされている最新バージョン Python 3.4.5 を使用してみてください。

1
Richie Bendall

Python 3.5 on XP互換性レイヤーを配置することにより、この男は何とか実行できましたDLL(XomPie)PythonおよびWindowsカーネルといじくり回し:
https://opensourcepack.blogspot.com/2016/10/python-352-on-xp.html

0
user