webdevqa.jp.net

"pip install unroll": "python setup.py Egg_info"がエラーコード1で失敗しました

私はPythonの初心者で、pipを使っていくつかのパッケージをインストールしようとしています。 

しかし、pip install unrollは私にくれます

コマンド "python setup.py Egg_info"が C:\ Users\MARKAN〜1\AppData\Local\Temp\pip-build-wa7uco0k\unroll \のエラーコード1で失敗しました

どうすればこれを解決できますか?

274
benjaminh

エラーコードについて

に従ってくださいPythonドキュメント

このモジュールは標準のerrnoシステムシンボルを利用可能にします。各記号の値は対応する整数値です。 名前と説明はlinux/include/errno.h から借用されています。

エラーコード1はerrno.hで定義されており、Operation not permittedを意味します。

あなたのエラーについて

あなたの setuptools はインストールされていないようです。 PyPI Webサイトの Installation Instructions に従ってください。

すでにインストールされている場合は、試してください。

pip install --upgrade setuptools

すでに最新のものであれば、モジュールez_setupが欠落していないことを確認してください。もしそうなら、

pip install ez_setup

それからもう一度やり直してください

pip install unroll

それでもまだ動作しない場合は、おそらくpipがsetup_toolsを適切にインストール/アップグレードしなかったため、試してみるとよいでしょう

easy_install -U setuptools

そしてまた

pip install unroll
158
pixis

Python + Windowsに新しいパッケージをインストールする方法を少し説明した小さなガイドです。 Windowsのパスを使っているように見えるので、この答えはその特定のSOに固執するでしょう。

  • 私はシステム全体のPythonインストールを決して使いません。私はvirtualenvsだけを使っています、そして通常私は2.xと3.xの最新バージョンを手に入れようとしています。
  • 私の最初の試みは、私のVisual Studioコマンドプロンプトの中で、常にpip install package_i_wantを実行することです。どのようなVisual Studioのコマンドプロンプトまあ、理想的にはPythonの構築に使用されたものと一致するVisual Studioです。例えば、あなたのPythonインストールがPython 2.7.11 (v2.7.11:6d1b6a68f775, Dec 5 2015, 20:40:30) [MSC v.1500 64 bit (AMD64)] on win32と言っているとしましょう。 Pythonのコンパイルに使用されたVisual Studioのバージョンは here にありますので、v1500はvs2008 x 64コマンドを使用することを意味しますプロンプト
  • 前の手順が何らかの理由で失敗した場合は、easy_install package_i_wantを使用してみてください
  • 前の手順が何らかの理由で失敗した場合は、 gohlke Webサイト にアクセスして、自分のパッケージが向こうにあるかどうかを確認します。もしそうなら、私は幸運です、私はちょうど私のvirtualenvにそれをダウンロードしてから私はただプロンプトコマンドを使ってその場所に行き、私はpip install package_i_want.whlをします
  • 前の手順でうまくいかなかった場合は、ホイールを自分で作成してみたら、pip install package_i_want.whlを付けてインストールします。

さて、もしあなたが unroll パッケージをインストールするのに苦労しているあなたの特定の問題に焦点を合わせるならば。それをインストールする最も速い方法は次のようなことをすることです:

  • git clone https://github.com/Zulko/unroll
  • cd unroll && python setup.py bdist_wheel
  • 生成されたunroll-0.1.0-py2-none-any.whlファイルを作成されたdistフォルダからあなたのvirtualenvにコピーします。
  • pip install unroll-0.1.0-py2-none-any.whl

そうすれば問題なくインストールできます。実際に動作することを確認するには、Pythonインストールにログインしてimport unrollを試すだけです。文句を言うべきではありません。

最後にもう1つ注意してください。このメソッドはほぼ99%の時間動作します、そして時にはあなたはUnixまたはMac OS Xに特有のいくつかのpipパッケージを見つけることがあります、その場合Windows版は主要な開発者に問題を投稿するか、自分でWindowsに移植して楽しんでください(運が悪くない場合は通常数時間):)

73
BPL

それはpipをアップグレードした後に解決されました:

python -m pip install --upgrade pip
pip install "package-name"
21
Lil Ari

私はpsycopg2と同じエラーで正確に動けなくなりました。 Pythonと関連パッケージのインストール中にいくつかのステップを飛ばしたようです。

  1. Sudo apt-get install python-dev libpq-dev
  2. あなたの仮想環境に行く
  3. pip install psycopg2

(あなたの場合はpsycopg2を問題のあるパッケージに置き換える必要があります。)

シームレスに動作しました。

17
SriSri

pip3を使用してmitmproxyをインストールしているときに同じエラーが発生しました。以下のコマンドはこれを修正しました:

pip3 install --upgrade setuptools
16
rashok
  • https://www.Microsoft.com/en-in/download/details.aspx?id=44266 からMicrosoft Visual C++ Compiler for Python 2.7をダウンロードしてインストールします。 Python 2.7パッケージ.
  • 昇格モードでコマンドプロンプトを開く(管理者として実行)
  • 最初にpip install ez_setupをする
  • 次にpip install unrollを実行します(numpy, music21, decorator, imageio, tqdm, moviepy, unrollのインストールが開始されます)#music21のインストールにはしばらくお待ちください

Python 2.7.11 64ビット使用

8
be_good_do_good

他の方法:

Sudo apt-get install python-psycopg2 python-mysqldb
4

Pipを使ってPythonモジュールをインストールしようとしたとき、私は同じエラーコードに遭遇しました。

その答えに基づいて、私の問題はSudoを前に付けてpip installコマンドを実行することで解決されました。

Sudo pip install python-mpd2
3
NP83

私は同じ問題を抱えていました。

問題は

pyparsing 2.2はすでにインストールされていて、私のrequirements.txtpyparsing 2.0.1をインストールしようとしましたが、このエラーが発生します

コンテキスト :私はvirtualenvを使っていましたが、2.2は私のグローバルOSのPython site-packagesから来たようですが、--no-site-packagesフラグ(今のところデフォルトでは最後のvirtualenv)を使っても2.2は存在しました。確かに私は彼らのウェブサイトからPythonをインストールし、それが私の$PATHにPythonライブラリを追加したからです。

たぶんpip install --ignore-installedはうまくいったでしょう。

解決策 :前に進む必要があるので、pyparsing==2.0.1からrequirements.txtを削除しました。

3
fadomire

私は "Twisted"ライブラリをインストールするときに同じ問題を抱えていて、Ubuntu 16.04(Xenial Xerus)で以下のコマンドを実行することによってそれを解決しました:

Sudo apt-get install python-setuptools python-dev build-essential
3
Adrian Onu

私は上のすべてを試しても成功しなかった。それから私は自分のPythonバージョンを2.7.10から2.7.13に更新し、それが私が経験していた問題を解決しました。

2
J_Heywood

それはpipの中のいくつかのパッケージが古いか正しくインストールされていないことを意味します。

  1. バージョンを確認してからpipをアップグレードしてみてください。それが機能する場合は、自動削除を使用してください。

  2. Pipコマンドが何らかのコマンドに対して常にエラーを表示したり、フリーズしたりした場合など。

  3. 最善の解決策は、それをアンインストールするか完全に削除することです。

  4. 新しいピップを取り付けてから、システムをアップデートおよびアップグレードします。

  5. 私はここに新鮮なpipをインストールするための解決策を与えました - python:ファイルget-pip.pyを開けませんエラー2]そのようなファイルまたはディレクトリはありません

2
jack_1729

.whlファイルを http://www.lfd.uci.edu/~gohlke/pythonlibs/ からダウンロードして、次のようにしました。

pip install scipy-0.19.1-cp27-cp27m-win32.whl

必要なバージョン(win32/win_AMD-64)は、Windowsのバージョンではなく、Pythonのバージョンによって異なります。

1
Vysh

私のWin10 PCに異なるパッケージを使用して同じ問題を抱えていて、これまでに述べたすべてのことを試してみました。

最後に Comodo Auto-Containmentを無効にすることで解決しました

誰もまだそれを述べていないので、私はそれが誰かに役立つことを願っています。

0
DaBrain

私は私の新しい開発環境で(pipenvと共に)virtualenvsを使ってこの問題を抱えていました。

Psycopg2のバージョンを2.6.2から2.7.3にアップグレードすることによってのみ解決できました。 詳細情報は にあります。https://github.com/psycopg/psycopg2/issues/594

0
Marco Silva

私はCentos 7でそれを使って解決しました:

Sudo yum install libcurl-devel
0
Ingenium

以下のコマンドは私のために働きました

[[email protected] ~]# pip install google-api-python-client==1.6.4
0
BigData-Guru

linuxを試してみてください。

Sudo apt install python-pip python-bluez libbluetooth-dev libboost-python-dev libboost-thread-dev libglib2.0-dev bluez bluez-hcidump
0

これは私にとってより簡単な方法でした。

pip2 install Name

あなたがpipを使っていたのであれば、 pip3 または pip2 を使ってみてください

それは問題を解決するはずです。

0
Zaman

私は同じ問題を抱えていて、以下をすることによって直すことができました。

Windows Pythonでは、setuptools.extension.Extensionやnumpy.distutils.core.Extensionなどのコードを構築するために、SDKを介してVisual C++ライブラリをインストールする必要があります。たとえば、Pythonを使用してWindowsでf2pyモジュールをビルドするには、上記のようにVisual C++ SDKが必要です。 LinuxおよびMacでは、C++ライブラリはコンパイラとともにインストールされます。

https://www.scivision.co/python-windows-visual-c++-14-required/ /

0
Prometheus

これは私のために働いた:

Sudo xcodebuild -license
0
Joshua Burkhart

Pythonをバージョン3にアップグレードすることで私の問題は解決しました。他に何もしませんでした。

0
Charles Jaimet

私は同じエラーメッセージで同じ問題に直面しましたが、Ubuntu 16.04 LTS(Xenial Xerus)を代わりに使用しました。

コマンド "python setup.py Egg_info"が/ tmp/pip-install-w71uo1rg/poster /のエラーコード1で失敗しました

私は上で提供されたすべての解決策をテストしました、そして、それらのどれも私のために働きませんでした。私は完全なTraceBackを読み、代わりにPythonバージョン2.7で仮想環境を作成しなければならないことを発見しました(デフォルトのものは代わりにPython 3.5を使用します)。

virtualenv --python=/usr/bin/python2.7 my_venv

有効にしたら、pip install unirestを正常に実行します。

0