webdevqa.jp.net

Ubuntuの場合:/usr/bin/python2.7を削除しました-助けてください

/usr/bin/python2.7実行可能ファイルを誤って上書きしてしまいました。で再インストールしようとすると

適性再インストールpython2.7

Python2.7をインストールするにはpython2.7が必要なため、失敗します。私は拘束されています。私はpython2.6をインストールしていますが、aptitudeはそれでは機能しません。

何か案は?本当にその実行可能ファイルを置き換える必要がありますが、どこにも見つかりません。

2
user475119

必要なパッケージはここからダウンロードできます。

http://packages.ubuntu.com/natty/python-minimal

次に、dpkgを使用してインストールします(実行するのにpython)は必要ないと思います):

Sudo dpkg -i python-minimal_2.7.1-0ubuntu5_all.deb

Ubuntu 11.04を実行していない場合は、Ubuntuのバージョンに合わせてpackages.ubuntu.comから正しいバージョンをダウンロードする必要がある場合があります。その場合、.debファイルのファイル名もdpkgコマンドで変更されます。

5
Victor

同様の問題解決済み 次のコマンドを使用しました:

Sudo dpkg --configure -a
Sudo apt-get -f install
Sudo apt-get --fix-missing install
Sudo apt-get clean all
Sudo apt-get update
Sudo apt-get upgrade
Sudo apt-get dist-upgrade
Sudo apt-get clean all
Sudo apt-get autoremove
2
unutbu

/ usr/binを調べましたか?おそらく他のバージョンのpython(他の実行可能ファイル)でpython2.7シンボリックリンクを作成できます

または、同じArchの別のマシンからビンをコピーします。

1
tMC