webdevqa.jp.net

React Nativeのアップグレード後に「verifyReleaseResources」エラーが発生する

アプリケーションをReact Native 0.57.1​​にアップグレードしようとしています。私はすべての手順を実行し、すべての適切なファイルをアップグレードしたと思いますが、まだ理解できないエラーが発生しています:

:react-native-document-picker:compileReleaseSources UP-TO-DATE
:react-native-document-picker:mergeReleaseResources UP-TO-DATE
:react-native-document-picker:verifyReleaseResourcesC:\Users\USERNAME\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.1.1.aar\b3b5480809d523e6f8b8de92faafbcda\res\values-v26\values-v26.xml:9:5-12:13: AAPT: error: resource Android:attr/colorError not found.

C:\Users\USERNAME\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.1.1.aar\b3b5480809d523e6f8b8de92faafbcda\res\values-v26\values-v26.xml:13:5-16:13: AAPT: error: resource Android:attr/colorError not found.

C:\Users\USERNAME\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.1.1.aar\b3b5480809d523e6f8b8de92faafbcda\res\values-v26\values-v26.xml:17:5-93: AAPT: error: style attribute 'Android:attr/keyboardNavigationCluster' not found.

C:\Users\USERNAME\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.1.1.aar\b3b5480809d523e6f8b8de92faafbcda\res\values\values.xml:251:5-69: AAPT: error: resource Android:attr/fontStyle not found.

C:\Users\USERNAME\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.1.1.aar\b3b5480809d523e6f8b8de92faafbcda\res\values\values.xml:251:5-69: AAPT: error: resource Android:attr/font not found.

C:\Users\USERNAME\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.1.1.aar\b3b5480809d523e6f8b8de92faafbcda\res\values\values.xml:251:5-69: AAPT: error: resource Android:attr/fontWeight not found.


error: failed linking references.
:react-native-document-picker:verifyReleaseResources FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':react-native-document-picker:verifyReleaseResources'.
> com.Android.ide.common.process.ProcessException: Failed to execute aapt

これらのエラーを本当に理解することはできませんが、それらが何を意味するのか分かりませんか?これを修正するにはどうすればよいですか?

.cacheディレクトリの削除、gradleバージョンの変更など、さまざまなことを試しましたが、何も役に立たないようです。何か案が?

26
laurent

プロジェクトのAndroid/build.gradleに次のコードを追加する必要があります。

subprojects {
    afterEvaluate {project ->
        if (project.hasProperty("Android")) {
            Android {
                compileSdkVersion 27
                buildToolsVersion "27.0.2"
            }
        }
    }
}
38
Sandy

エラーの理由:

依存関係としてreact-native-document-pickerをインストールしました。このエラーの理由は、Android/app/build.gradlenode_modules/react-native-document-picker/Android/build.gradle不一致。

ソリューション

  1. node_modules/react-native-document-picker/Android/build.gradleに移動します
  2. compileSdkVersionbuildToolsVersionminSdkVersiontargetSdkVersionを編集して、Android/app/build.gradleにあるものと同じにします
  3. プロジェクトを再度同期します。
  4. ターミナルから./gradlew assembleReleaseを実行します。
5
Hadi Mir

この問題の別の理由がありましたが、以前にminSdkVersionを変更していました。必要なのは、/ node_modules /フォルダー、/ Android/buildおよび/ Android/app/buildフォルダーを削除し、npmインストールを再実行して、。/ gradlew assembleReleaseを再度実行することだけです。

0
morph85