webdevqa.jp.net

@ react-navigation / bottom-tabs 5.xが原因の起動エラー

以前の5.xから最新の@ react-navigation/stack 5.2.10にアップグレードした後。アプリ(React Native 0.61.5)の起動にエラーがあります:

error: bundling failed: SyntaxError: C:\D\code\js\emps_fe615\node_modules\@react-navigation\bottom-tabs\src\index.tsx: Unexpected token (15:12)

  13 |  * Types
  14 |  */
> 15 | export type {
     |             ^
  16 |   BottomTabNavigationOptions,
  17 |   BottomTabNavigationProp,
  18 |   BottomTabBarProps,
 BUNDLE  [Android, dev] ./index.js ▓▓▓▓▓▓▓▓▓▓▓▓░░░░ 75.5% (802/923)::ffff:127.0.0.1 - - [11/Apr/2020:02:14:43 +0000] "GET /index.bundle?platform=Android&dev=true&minify=false HTTP/1.1" 500 - "-" "okhttp/3.12.1"
 BUNDLE  [Android, dev] ./index.js ▓▓▓▓▓▓▓▓▓▓▓▓░░░░ 75.5% (802/923), failed.

これがpackage.jsonの一部です。

"@react-navigation/bottom-tabs": "^5.2.6",
"@react-navigation/native": "^5.1.5",
"@react-navigation/stack": "^5.2.10"
"react-native-gesture-handler": "^1.6.1",
"react-native-screens": "^2.4.0",

アップグレード後にエラーが発生する人はいますか?それを修正するアイデアはありますか?

2
user938363

以下の手順は問題を解決します。

npm install @babel/[email protected]^7.9.0
npm install @babel/[email protected]^7.9.2
npm cache clean --force
expo start -c
1
Sridhar