webdevqa.jp.net

Ubuntu Rails zlibでインストールが失敗する

開発ボックスとしてUbuntu 8.10に移行しました。 Linuxを毎日使用するOSとして初めて真剣に取り組んでおり、Railsを取得するのに苦労しています。 gem installまたはgem updateを使用しようとすると、次のようなエラーが表示されます。

/usr/local/lib/Ruby/site_Ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- zlib (LoadError)
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/spec_fetcher.rb:1
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/commands/update_command.rb:5
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/command_manager.rb:167:in `load_and_instantiate'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/command_manager.rb:88:in `[]'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/command_manager.rb:144:in `find_command'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/command_manager.rb:131:in `process_args'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/command_manager.rb:102:in `run'
from /usr/local/lib/Ruby/site_Ruby/1.8/rubygems/gem_runner.rb:58:in `run'
from /usr/local/bin/gem:21

(チュートリアルで推奨されているように)zlib、zlib1g、およびzlib1g-devをインストールしました。私はこの特定の問題に関するいくつかのチュートリアルさえ見つけました(ただし、すべて私のもの以外のフレーバー向けです)が、助けにはなりませんでした。

私はUbuntu 8.10を使用しています。Rubyバージョン1.8.8dev gemバージョン1.3.2

Rubyとgemをそれぞれ個別に再インストールしてみましたが、役に立ちませんでした。

129
Paul

Ubuntu 10.04でRuby Ruby Version Manager(RVM)を使用してバージョンマネージャー(RVM)をインストールしようとすると、rvm Webサイトにzlibをインストールする手順があります。 http://rvm.beginrescueend.com/packages/zlib/

手順は次のとおりです。

rvm pkg install zlib

(または rvm package install zlib「ERROR:Unrecognized command line argument: 'pkg'」というメッセージが表示された場合-旧バージョンのrvmは代わりに動詞 'package'を使用していました)

それから

rvm remove 1.9.1
rvm install 1.9.1
297
JosephL

Ubuntu 10.04(Lucid)を使用しています。Railsでは1.9.1が推奨されていないため、Ruby 1.9.2をインストールしたいと考えました。ソースディストリビューションはRuby-1.9.2-p0で、解凍した後、zlibを次のようにビルドしました。

cd Ruby-1.9.2-p0/ext/zlib
Ruby extconf.rb
make
Sudo make install
Sudo gem install Rails

それは問題を修正しました。これは他の人が上に投稿したものと似ていますが、正確にはそうではないので、私はそれを実現するために私がしたことを正確に投稿することも考えました。

52
AdrianVeidt

CentOSでも同じ問題があり、次のコマンドを実行して修正します。

最初に、zlibとzlib-develが存在することを確認します(上記で提案されている多くのものと同様)。

yum install zlib zlib-devel

次に、Rubyに付属のzlibのソースを再コンパイルしてインストールしました。

cd /home/myname/installers/Ruby-1.8.7-p174/ext/zlib/
Ruby extconf.rb --with-zlib-include=/usr/include --with-zlib-lib=/usr/lib
make
make install

そのコマンドは問題を解決するようで、gem update --systemを実行すると、zlibのエラーは消えました。次に、Rails gem install Railsをインストールします。zlibを再コンパイルしてインストールした前にgemをインストールしたことがあることに注意してください。アンインストールするためのスクリプトが見つからないため、アンインストールします)

それは私のために働く...あなたに願っています。

よろしく。

22
Daniel

試してみる

aptitude install zlib1g-dev

次に、あなたのビジネスに取り掛かります。

13
Dan

私は本当にこれらの答えが好きではありませんでした...ユーザーの実際のニーズと質問に本当に焦点を当てたものはありませんでした...彼らが何をしたかを伝える人々...コンテキストなしで、それは私にとってもうまくいきませんでした...

そう、 ..

新しいボックスUbuntu 8.04 LTS 64ビットをインストールしています...

だから、私は...

cd ~  
wget ftp://ftp.Ruby-lang.org//pub/Ruby/1.9/Ruby-1.9.2-p180.tar.gz  
tar -xvvf Ruby-1.9.2-p180.tar.gz  
cd Ruby-*  
./configure  
make  
install  
Sudo make install  

そして、私はこの問題を抱えています...

gem list

それは動作しません... zLibについて何かがらくたが見つかりませんでした...

だから、私は実際にREADMEを読んで、ファイルを編集する必要があることがわかります...

[my Ruby source directory]/ext/Setup

そして、zLibを含む行をコメント解除します...最初の列の「#」を削除する

次に、コマンドを再度実行します...参照用にここに含まれています...

./configure
make  
install  
Sudo make install  

そして、すべては順調です...それは論理的です...そして、「rvm」と他のものがありません...「それを機能させるためにもっと多くのものをインストールするだけ」タイプのソリューション。

ジョート

8
Knowself

Goto Ruby Source Package、解凍します。

/ your-Ruby-dir/ext/zlibに移動します

Ruby extconf.rb
make
Sudo make install

パッケージが欠落している場合は、主にlibzlib関連のパッケージが表示されます

よろしく

サウラブ

7
Saurabh
rvm package install zlib
rvm remove 1.9.1
rvm install 1.9.1

それでした。たくさんの野生のガチョウの追跡の後、私はこのページを見つけてうれしいです。

6
Rod McLaughlin

はい、それでも仕事をしませんでした。別のソースからこれを取得し、これは最終的に他のものが失敗した私のためにそれをやった。

wget http://www.blue.sky.or.jp/atelier/Ruby/ruby-zlib-0.6.0.tar.gz
tar xvzf Ruby-zlib-0.6.0.tar.gz
cd Ruby-zlib-0.6.0
Ruby extconf.rb && make
Sudo make install

再インストールRubyソースからの宝石

とにかくありがとう、みんな。

4
Paul

Debian(Squeeze)の場合:

librubyには、Debian上でRubyを適切に動作させるために必要な他のすべてのものの中のRubyのzlibが含まれています。そう...

apt-get install libruby

その後...

cd /usr/local/src/Ruby
make clean
make
make install
cd ../rubygems
Ruby setup.rb
gem install Rails

これでうまくいきましたが、走行距離は異なる場合があります。必要なものがすべてlibrubyでカバーされていることに気付く前に、zlibへのわずかなショットガンアプローチを行いました。

2
Tryst

Apt-get install libzlib-rubyを試しましたか?

また、rubyforgeからrubygemsをインストールします。 Ubuntuのrubygemsパッケージは好きではありません。

2
nkassis

問題は、Rubyはzlibに対してビルドされていないため、Rubyをインストールするためにソースビルドを実行する必要があることです。これはapt-get source -b Ruby

2
Don Werve

phusion サイトでRubyエンタープライズdebパッケージをダウンロードしてみてください。パッケージから乗客をインストールします。指示 here または、見つかったbashスクリプトを試すこともできます here

1
Maran

Railsを実行するとき、Ruby 1.8.8devの使用はお勧めしません。 1.8.6、できればRuby Enterprise Editionを使用してください。 RailsLab の他の人が使用しているものに関するこの投稿を参照してください。

ハイテクにこだわる場合は、Ruby 1.9.1をインストールしてください。

ただし、どちらの場合も、自分で作成するか、Maransの提案を使用してください。

0
harm