webdevqa.jp.net

優先Ruby Eclipseのプラグイン?

RDT(Ruby Development Tool)は、EclipseにRubyサポートを追加するための推奨プラグインのようです。 EclipseでRubyの最新版ではありませんか?

その場合、どのプラグインが最近好まれ、最良の選択ですか?

73
Lee Tang

Rubyの Dynamic Languages Toolkit を試してください。 EclipseのSoftware Updatesパネルから入手できます。

91

良い質問。私はAptana/radrailsを使用しましたが、これは絶対に避けなければなりません。

Eclipseを起動するディレクトリにデータベースを書き込み、一般的にEclipseを引き継ぎ、多くの便利なキーバインディングを変更します。

最も刺激的なことの1つは Ctrl-1 Javaファイルで動作を停止し、それは私が使用するホットキーですall時間。

良いものを知りたいので、これに関する人々の答えを聞くのを楽しみにしています。

18
Don Branson

更新サイトはここにあるように見えます: http://download.Eclipse.org/technology/dltk/updates/

Www.Eclipse.org/dltk/install.phpで見つけました

12
Fitz

この問題 Eclipseのaptana studioプラグインをインストールした後、直面しました。そこで、Eclipse用の動的言語ツールキットを試すことにしました。

Aptanaプラグインをアンインストールする場合:Eclipse> Help> About Eclipse> Installation Details> Installed Software tab> Aptana plugin> Uninstall。これにより、クリーンでフラストレーションのないアンインストールが行われます。

次に、DLTKプラグインをインストールします。

リンクに移動- http://marketplace.Eclipse.org/content/Ruby-dltk 。緑色の下矢印を押します。ポップアップからリンクをコピーします。

enter image description here

Eclipse>ヘルプ>新しいソフトウェアのインストール>コピーされたリンクの処理。

プラグインのリストが表示されます。そのリストで、[プログラミング言語]を展開し、次のチェックボックスをオンにします。動的言語ツールキット-Ruby開発ツール>ボタンを押す:次へ>明らかな手順。

この後、 http://rubyinstaller.org/ でWindows用のRubyInstallerをインストールします。このインストールで作成されたRuby.exeの場所を見つけます。これは、最初のEclipse Rubyプロジェクトを作成するときにRubyインタープリターを設定するために必要になります。

Rubyプロジェクトを正常に作成すると、EclipseはRubyパースペクティブを開くかどうかを尋ねます。いいよ動作するかどうかをテストするには、Rubyプロジェクトを作成してから、このプロジェクト内に空のRubyスクリプトを作成します。次に、このコマンドputs "hello Ruby"をRubyスクリプトとして実行します。輝くRubyをお楽しみください!

6
james

私は過去にAptana/RadRailsを使用しましたが、それを十分に楽しんでいます。試してみることをお勧めします。必要な場合は、Rails以外のプロジェクトも適切にサポートするスタンドアロンのEclipseプラグインが利用可能です。

ただし、Eclipseでの私の唯一の経験はAptanaを介したものであったため、他の考慮事項があるかもしれません。

2

Dynamic Languages Toolkit(DLTK)が推奨されます。 Eclipseでの段階的なインストール:

  1. Eclipseを開く
  2. ヘルプ-> "Eclipse Marketplace ..."に移動します
  3. [検索]テキストボックスに「DLTK」と入力し、[移動]ボタンをクリックします
  4. Ruby(DLTK)セクションの下にある[インストール]ボタンをクリックします
  5. Eclipseポップアップの指示に従います

インストールが成功した後のインストールの検証:

Window-> Preferencesに移動すると、左側のパネルに「Dynamic Languages」と「Ruby」が登録されています

2
Ripon Al Wasim