webdevqa.jp.net

Linux(ubuntu)でRuby=を更新するには?

私はRubyとlinuxの両方に慣れているので、これは些細なことだと確信していますが、まだわかりません。現在、Ruby 1.8。 7がインストールされ、Ruby 1.9に更新したいのですが、どうすればよいですか?

42
eKek0
Sudo apt-get install Ruby1.9

トリックを行う必要があります。

インストール可能なライブラリを見つけるには

apt-cache search <your search term>

だから私はapt-cache search Ruby | grep 9を見つけます。

おそらく、新しいRuby as Ruby1.9。これは、Rubyと入力するだけでUbuntuのデフォルトが1.8になるためです。

54
Mark Rushakoff

他の誰かがよく知っている場合を除き、Ruby1-8を削除する理由は本当にありません。以下のコマンドを実行して1.9をインストールし、リンクRubyで新しいバージョンを指すようにします。

Sudo apt-get install Ruby1-9 rubygems1-9
Sudo ln -sf /usr/bin/Ruby1-9 /usr/bin/Ruby
36
Chris

Ubuntu 12.04(Precise Pangolin)では、次のコマンドでこれが機能しました。

Sudo apt-get install Ruby1.9.1
Sudo apt-get install Ruby1.9.3
16
Zorayr

Rubyは現在v2.0です。 Jekyll(および私は他の多くの人もそうです)のようなプログラムはそれを必要とします。私はちょうど走った:

Sudo apt-get install Ruby2.0

バージョンを確認する

Ruby --version

役立つことを願っています

11
user7542

この記事 の作者は、Rubyをローカルパケットマネージャーからインストールするのを避け、代わりに〜#〜] rvm [〜#〜]

異なるバージョン間で簡単に切り替えることができますRuby=

rvm use 1.9.3

等.

8
Konrad Reiche

上記は悪いことではありませんが、11.10では少し異なります

Sudo apt-get install Ruby1.9 rubygems1.9

インストールされますRuby 1.9

リンクするときは、ls /usr/bin | grep Ruby出力されるはずですRuby1.9.1

それであなたはSudo ln -sf /usr/bin/Ruby1.9.1 /usr/bin/Rubyとレースへの出発。

4
kenobi

あなたがubuntu 10.10を使用しているような場合、現在の最新バージョンを見つけることができません

  • Ruby1.9.3

ここから入手できます http://www.ubuntuupdates.org/package/brightbox_Ruby_ng_experimental/maverick/main/base/Ruby1.9.

または*。debファイルをダウンロードします:)

そして、それはあなたを変えないことを覚えておいてくださいRubyの古いバージョン

1
ucefkh

まず、使用しているubuntuのバージョンは、それを持っているものにアップグレードするのが最も簡単かもしれません。

次に、バックポート(システムメニュー、管理、ソフトウェアソース)を有効にし、シナプスで検索します。

最後に、PPAを探します。

1
Ronald Pottol

通常、プログラムのバージョンはオペレーティングシステムのバージョンにリンクされています。したがって、gutsyを実行している場合は、Ruby 1.9を持つ新しいjaunty jackalopeバージョンにアップグレードするか、/ etc/apt/sources.listファイルにjauntyのリポジトリを追加する必要があります。これで、シナプスパッケージマネージャーを起動でき、そこに表示されるはずです。

0
mikewilliamson