webdevqa.jp.net

MacでRubyを1.9.xに更新する方法は?

Macで新しいユーザーアカウントを作成し、snow leopardのデフォルトの1.8.7からRubyの現在のバージョン(1.9.2)に更新しようとしています。誰かが私にチュートリアルを教えたり、MacのRubyを1.8から1.9.2に更新する最良の方法を説明できますか?ありがとう

107
agentbanks217

rvm を強く提案します。

これは、システムバージョンと競合することなく、複数のルビーと宝石のセットを管理するための素晴らしい方法です。


これを追加します(4/2/2013)。私のニーズは単純なので、 rbenv をたくさん使用します。 RVMは優れていますが、必要のない多くの機能を備えているため、一部のマシンではRVMを、デスクトップやラップトップではrbenvを使用しています。両方をチェックして、どちらがニーズに最適かを確認する価値があります。

66
the Tin Man

AsThe Tin Man提案(上記)RVMRubyバージョンマネージャー)は、OSX上のRubyインストールをアップグレードするための標準です。 https://rvm.io =

開始するには、Terminalウィンドウを開き、次のコマンドを発行します。

\curl -L https://get.rvm.io | bash -s stable --Ruby

trustコマンドが悪意のないRVM開発チームである必要があります-あなたが私のようなパラノイドペンギン、いつでもソースを読むことができます: https://github.com/wayneeseguin/rvm =)完了したら、rvmコマンドを機能させるためにターミナルを再起動する必要があります

rvm list known

(Rubyの最新バージョンを表示します)

rvm install Ruby-2.3.1

特定のバージョンの場合、その後に

rvm use Ruby-2.3.1

or最新の(現在の)バージョンが必要な場合:

rvm install current && rvm use current

(現在の安定版リリースをインストールします-Ruby-2.3.1を書いている時点で-新しいバージョンがリリースされたらこのwikiを更新してください)

Rubyのコンパイルに関する注意:私の場合、Homebrewもインストールする必要がありました http://mxcl.github.com/homebrew/gemsを取得するには( RSpec )順番にインストールを強制しますXcode(まだインストールしていない場合) https://iTunes.Apple.com/us/app/xcode/id497799835AND/OR以下からGCCパッケージをインストールします https://github.com/kennethreitz/osx-gcc- installermake」の実行エラーを回避します。

編集:Mavericks現在、全体ではなくXcodeコマンドラインツールのみをインストールすることを選択できますXcodeパッケージ。gccや、パッケージの構築に必要な他の多くのものが付属しています。 xcode-select --installを実行し、画面上のプロンプトに従ってインストールできます。

エラーに関する注意:エラーが表示された場合、「RVMは関数ではありません "このコマンドを試している間に、次のサイトにアクセスしてください。 RVMを使用してRubyバージョンを変更するにはどうすればよいですか? ソリューション.

198
nelsonic

Brewでは、これはワンライナーです。

(homebrew/versionsをタップしたと仮定します。これはbrew tap homebrew/versionsを実行することで実行できます)

brew install Ruby193

OS X 10.8.4ですぐに使えるようになりました。または、2.0が必要な場合は、brew install Ruby

より一般的には、brew search Rubyは利用可能な異なるリポジトリを表示します。本当に特定したい場合は、代わりにbrew versions Rubyを使用して特定のバージョンをチェックアウトできます。

19
Nils

私はそれが古い投稿であることを知っていますが、それについていくつかの追加情報を追加したいと思います。最初に、rvmは素晴らしいであると思いますが、はシステムからRubyを更新していません(MAC OS Yosemite)。

rvmは何をしていましたか:別の場所にインストールし、そこに環境変数へのパスを設定します...そして、システムにRubyが2つあったので、ちょっと退屈しました。

それを修正するために、rvmをアンインストールしてから、Homebrewパッケージマネージャーを使用して here を使用し、Ruby throw terminalコマンドを実行してbrew install Rubyを実行しました。

そして、すべてが完璧に機能していました!システムのRubyが更新されました!それが次の冒険者に役立つことを願っています!

4
Damiii

ここでThe Tin Manに反対します。 rbenv はRVMよりも望ましいと考えています。 rbenvは、RVMのようにシェルを大幅に妨害することはなく、直接検査できる通常のフォルダーに別個のRubyインストールを追加できます。 Rubyを自分でコンパイルできます。ここの違いの概要: https://github.com/sstephenson/rbenv/wiki/Why-rbenv%3F

Rbenv here のRuby 1.9をコンパイルする手順を提供します。さらに、より詳細な情報 ここ 。 Snow Leopard、Lion、Mountain Lionで簡単に成功してこの手法を使用しました。

3
matt

Dan BenjaminのHivelogicの記事 Snow LeopardにRuby、RubyGems、およびRailsをインストールする が推奨されている場所ですが、この記事は1.8向けであるため、ここに Ruby 1.9- Snow Leopardへの特定のインストール 。 64ビットのことに注意してください...すべての64ビット「ファット」(たとえば-32ビットライブラリで問題を引き起こす可能性のあるOS X上のApache)に行くか、可能性のある宝石をチェックしてください64ビットで問題ないことを確認するために使用します。

2
Dave Everitt

このコマンドは実際に動作します

\curl -L https://get.rvm.io | bash -s stable --Ruby

2
Anthony

前述のように、BundlerのバージョンはRailsのバージョンに対して高すぎる可能性があります。

Bundler v1.0.0-v1.0.22を必要とするRails 3.0.1を使用して同じ問題に遭遇しました

gem list bundlerを使用してバンドラーのバージョンを確認します

バンドラーのバージョンが適切な範囲内にない場合、このソリューションが機能することがわかりました:rvm @global do gem uninstall bundler

注:このソリューションにはrvmが必要です...そもそもrvmを使用する理由の別のケースです。

0
whiteshooz

他にも考慮すべきバージョンマネージャがいくつかあります。 いくつかの例を参照 と、リストにないもののうち、すぐに試してみるものは ch-Ruby です。 rbenvを試しましたが、問題が多すぎました。 RVMは私の主力ですが、時々奇妙な問題を抱えています(そのため、機会があればch-Rubyを試してみたいと思っています)。他の物事がそれに依存するかもしれないので、私はシステムRubyに触れないでしょう。

また、自分でRubyを数回コンパイルしたので、Hivelogicの記事(Dave Everittが示唆したように)を使用することをお勧めします。

0
iain