webdevqa.jp.net

iOS8.0.2ライブラリがロードされていませんlibswiftCore.dylib

HealthKitとSwiftを使用するアプリケーションがあります。シミュレーターまたはデバイスで、Xcodeからテストすると、すべてが正常にコンパイルおよび実行されます。テスト、デバッグ、および送信しました。 iTunesストア。アプリケーションが承認されたとき、ストアから新しいバージョンをダウンロードするとすぐにクラッシュしました。これまでこの問題が発生したことがないため、これは非常に不可解でした。電話の診断ログと使用状況ログ、およびクラッシュレポートを確認します。アプリケーションはこれを言います:

Dyldエラーメッセージ:ライブラリがロードされていません:@ rpath/libswiftCore.dylib参照元:/ path/to/my/app理由:適切な画像が見つかりません。見つかりました:/path/to/my/app/Frameworks/libswiftCore.dylib:アドレス= 0x100174000、サイズ= 0x0194000セグメント= __ TEXTのmmap()エラー1、Segment :: map()

誰かがこのようなものを見たことがありますか、それを処理する方法を知っていますか?

ありがとうございました

編集:

クラッシュの問題は10月4日の朝に魔法のように修正され、これはAppleの問題でした。私はiTunesConnectサポートにメールを送っていますが、彼らはなんらかの形で何を言っていません。 Appleが問題について透明性を欠いているという事実だけでなく、それは私を私にさせます。これは、Appleからの応答さえもなしにテクニカルチケットを開きました。これはかなり残念です。これが再び起こった場合、私は後で行動のコースがないように感じます。

19
AgnosticDev

次の2つの手順を実行するだけです。

1)デバイス(またはシミュレーター)からアプリを削除します

2)ワークスペースをクリーンアップします(CMD + SHIFT + KまたはメニューProduct-> Cleanを使用)

3)アプリをビルドして再度実行します。

起動/デプロイのすべてを魔法のように支援します...

また、「アプリケーションがデバイスに見つかりません」や署名の問題などが発生することもよくあります。すべてが正常に機能する数分前。

7

これはApple側のコード署名の問題である可能性があり、この問題はフレームワークが組み込まれたアプリ(Swift以外のアプリを含む)に影響を与えるようです。ビルド設定を変更せずに更新を送信しただけの、影響を受けている開発者(私自身を含む)のアカウントが複数あります。一部の有名なアプリは影響を受けているようで、チケットはAppleに提出されていますが、現時点では公式の回答はありません。

編集:これは確認されています。

6
rjsamson

アプリのバージョンアップデートの1つ(FunKeyBoard 1.1)でもまったく同じ問題が発生しました。

調査を行ったところ、10月3日に更新された多くのアプリのApple副次的な問題でした。Apple 10月4日に更新をリリースして問題を修正しました。 、同じバージョン番号。アプリ開発者からの修正/再アップロードは必要ありません。

明らかにApple副次的な問題ですが、私は驚いていますAppleはそれについて非常に静かです。私を含む多くの開発者は、ユーザーから怒ったメールを受け取り、貧しい人々です結果として、アプリのレビュー。

2
Enrico Pangan

このエラーは通常、「OU」(組織単位)がない証明書を使用してSwiftアプリに署名するときに発生します。iOS8のリリース後に作成されたすべての証明書にこれが必要です。簡単な解決策は、新しいものを作成することです。署名する証明書。

詳細については、公式のAppleコメントはこちら: https://developer.Apple.com/library/ios/qa/qa1886/_index.html

2
emidander

編集:

この変更を行った後、同じ理由でアプリが拒否されましたが、問題はlibswiftCoreにアーキテクチャバージョンがないことに関係していると確信しています。


これを暫定回答として掲載します。 Xcode 6標準アーキテクチャはarmv7sを除外します

エラーの内容に注意してください:見つかりました:/path/to/my/app/Frameworks/libswiftCore.dylib

したがって、libは見つかりましたが、次のようにも表示されます:理由:適切な画像が見つかりません。

アーカイブされたビルドに対してlipoを実行した後、Swiftライブラリまたはアプリバイナリにarmv7sが含まれていませんでした。上記のリンクに従って手動で追加しましたが、バイナリにはarmv7sのサポートが含まれています。 Swiftライブラリはまだありませんでした。私のアプリは迅速にレビューされているので、すぐにフィードバックを受け取る必要があります。それが発生した場合はフォローアップします。

2
maxpower

私も同じ問題を抱えていました。 arm64のサポートを削除し、armv7sを追加しました。現在、Appleレビューチームがアプリを承認しています。

私のiTunesストアは、期待どおりにダウンロードして開いているようです。 Apple Developer Forums で読んでいることから、他のアプリも現在機能しています。 Appleから、なぜこれが起こったのか、何が原因なのかについての言葉を受け取っていません。彼らとテクニカルサポートチケットを開いて、iTunes Connectサポートにも連絡しましたが、説明も情報もありません。この問題は解決されています。これは彼らの側ではかなり貧弱なカスタマーサービスです。

0
AgnosticDev