webdevqa.jp.net

テーマカスタマイザーがロードされていません

私は新しいテーマを作成しました、そして私は私のいくつかのサイト(マルチサイト)でそれを使います、しかしあるサイトでカスタマイザプレビューはロードしません(スピナーは決して止まりません)。他のテーマのカスタマイザプレビューをロードしてもうまくいきません。

クロム開発ツールのコンソールにエラーはありません。

だから私はいくつかのことを試してみました...

  • テーマの名前を変更しました(フォルダおよびstyle.css内)
  • 空のindex.phpと必要なコメントだけを含むstyle.cssだけが残るように、すべてのファイルを削除しました。

しかし、これもまた、私のマルチサイトの1つにしかかかりません。

どうすればこれをデバッグできますか?何か案は?

2
dknaack

また、あなたの親テーマのスタイルがあなたの子テーマの前に追加されていることを確認してください。これをあなたの子供のテーマの "functions.php"ファイルに入れて、それが役立つかどうか確認してください:

// Flush all output buffers in PHP:
remove_action('shutdown', 'wp_ob_end_flush_all', 1);

// Making sure your child theme has an independent version and can bust caches: http://wordpress.stackexchange.com/a/182023/30783

// Filter get_stylesheet_uri() to return the parent theme's stylesheet
add_filter('stylesheet_uri', 'use_parent_theme_stylesheet');

// Enqueue this theme’s scripts and styles (after parent theme)
add_action('wp_enqueue_scripts', 'my_theme_styles', 20);

function use_parent_theme_stylesheet()
{

// Use the parent theme’s stylesheet
return get_template_directory_uri() . '/style.css';
}

function my_theme_styles()
{
$themeVersion = wp_get_theme()->get('Version') . Rand();

// Enqueue our style.css with our own version
wp_enqueue_style('child-theme-style', get_stylesheet_directory_uri() . '/style.css',
array(), $themeVersion);
}
1
FirstFraktal

カスタマイザ(ライブプレビュー)が機能しない、または読み込まれず、何も表示されない場合は、次の手順を試してください。

  • 問題のあるサイトにリダイレクトがありますか(ダブルチェックして確認してください。プラグイン/コードにカスタムリダイレクトがコーディングされている可能性があります)。
  • サークルがまだロードされている間に、カスタマイザのオプションを変更して「保存して公開」をクリックして参照してください。多分簡単な変更でサイトが発生するでしょう。
  • プラグインを無効にしてみてください。
  • コアの.phpファイルにプログラムされたカスタムのEXIT/ DIE/ VAR_DUMP/ ECHO/ SETCOOOKIE/コマンドがありますか。これは、いくつかの条件が満たされない場合にWebサイトの読み込みを停止する可能性がありますか? (例えば、私は私によって引き起こされた同様の問題を抱えていました:すなわちIF (isset($_COOKIE["blabla"])) exit;
  • 新しいWPを別のURLでインストールし、最初にテーマのみをインストールして確認してください。それからすべてをインポートして、もう一度確認してください。違いがないか確認してください。
1
T.Todua

私はIEでは問題なく動作していたがChromeでは動作していなかったカスタマイザを持っていました(Chromeでは何も表示されません)。これは私にとってこの問題を解決したものです。

わかりやすくするために、ワードプレスのカスタマイザは右側がまったく空白になっていました(ただしChromeの場合のみ)。 「コンテンツセキュリティポリシーディレクティブ: "frame-ancestors 'self'"に違反しているため、IFrameコンテンツの読み込みを拒否することに関するエラーが(コンソールで)発生しました

修正は私の開発ドメインに別のドットを追加することでした。

つまり、ローカルのdevドメイン名に単一のドット - http://foo_online.local が付いていて、この問題が発生していました。 http://foo.online.localに切り替えた後 問題は解決しました。

(ドメイン名を変更した後は、ダッシュボードの[全般設定]でWordPressアドレス(URL)サイトアドレス(URL)を更新することを忘れないでください)。

私は明白な "Content Security Policy"ヘッダー(あなたがあなたのウェブサーバー設定で構成する)を設定しようとしましたがChromeを幸せにするような設定を見つけることができませんでした。お役に立てれば。

0
utunga