webdevqa.jp.net

XFCEテーマの色を変更する

XFCEでGreybirdのようなテーマの色を変更できるのに、Clearlooks-Phenixで変更しようとすると、一部のアプリケーションで色が適用されないのはなぜですか?

1
Waterscroll

Clearlooks-Phenixのgtk3部分は、テーマの色を変更するアプリケーションでは機能しません。 gtk3に更新されたアプリケーションは、選択された色を持ちません。

Clearlooksの色を完全に変更するには-gtk-variant.cssおよびimgフォルダーにある画像の色を編集するためにPhenixが必要です。

1
Waterscroll

まず第一に、 clearlooks-phenix github page は、適切なバージョンのテーマをダウンロードしてインストールする必要があることをREADME.mdにすでに記載しています。

GTKバージョンの互換性

主な理由は、テーマを正しく適用するには、使用中のGTKツールキットの特定のバージョンをサポートするテーマを使用する必要があるためです。

状況に応じて適切なバージョンをダウンロードします。

  • gTK 3.0および3.2の場合:Clearlooks-Phénixv1をダウンロードします。

  • gTK 3.4の場合:Clearlooks-Phénixv2をダウンロードします。

  • gTK 3.6の場合:Clearlooks-Phénixv3をダウンロードします。

  • gTK 3.8の場合:Clearlooks-Phénixv4をダウンロードします。

  • gTK 3.10および3.12の場合:Clearlooks-Phénixv5をダウンロードします。

  • gTK 3.14の場合:Clearlooks-Phénixv6をダウンロードします。

GTKバージョンを見つけるには:

  • パッケージマネージャーで、パッケージlibgtk-3-0のバージョンを確認できます。

  • Ubuntuを使用している場合、そのバージョンとGTKのバージョン(Ubuntuのデフォルトインストールの場合)の対応は次のとおりです。

    • Ubuntu 11.10:GTK 3.2

    • Ubuntu 12.04:GTK 3.4

    • Ubuntu 12.10および13.04:GTK 3.6

    • Ubuntu 13.10:GTK 3.8

    • Ubuntu 14.04:GTK 3.10

    • Ubuntu 14.10:GTK 3.12

たとえば、ホストシステムがUbuntu 14.04(GTK 3.10に同梱)を実行している場合は、Clearlooks-Phénix v5をダウンロードしてインストールする必要があります。

テーマ別のGTKサポート

XFCEでGreybirdのようなテーマの色を変更できるのに、Clearlooks-Phenixで変更しようとすると、一部のアプリケーションで色が適用されないのはなぜですか?

Greybird は、Xfceのテーマを組み込んだShimmerProjectの一部です。これは、LinuxディストリビューションXubuntuのデフォルトのテーマでもあります。プレインストールされたアプリケーションは、適切なGTKバージョンとすでに一致しているため、通常、デフォルトのテーマと最も互換性があります。

そのため、これらの「一部のアプリケーション」は、他のアプリケーションとは異なるGTKツールキットバージョンを使用している可能性があります。システムでGTKツールキットのバージョンをアップグレードしても、notリポジトリ内のすべてのアプリケーションは、最新のテーマに対応できるように十分に更新されます。

同じプロジェクト で作成されたテーマの中でも、Greybirdは、BluebirdやAlbatrossなどの古いテーマと比較して、GTK2とGTK3の両方をより適切にサポートしています。 Xubuntu 12.04と14.04でこれらのデフォルトのテーマをすでに経験しているので、私はこれを知っています。

0
user109256