webdevqa.jp.net

グローバルvue-cliインストールを最新バージョンにアップグレードするにはどうすればよいですか?

すでにvue-cli 3.5.5がインストールされています。 vue create myappを実行すると、メッセージUpdate available 3.6.2が表示されます。

Vue CLI v3.5.5
┌───────────────────────────┐
│  Update available: 3.6.2  │
└───────────────────────────┘

Vue-cliを最新バージョンにアップグレードするにはどうすればよいですか?

npm i -g vue-cliを実行すると、既存のvue cliバージョンをアップグレードする代わりに、vue-cliバージョン2.9.6がインストールされます。

OS:Ubuntu 18.04.1。

ノードのバージョン:10.15.3。

nvmバージョン:0.34.0。

9
Antony

vue-cli 3.xは@ vue/cliに変更されました。したがって、直接のアップグレードはありません。

  1. 古いバージョンが不要になった場合、または最新のインストールコマンドでエラーが発生した場合は、古いバージョンをアンインストールします。
npm uninstall -g vue-cli
  1. 次のコマンドを使用して、最新のvue-cliバージョンをインストールします。
$ npm install -g @vue/[email protected]

ノート

  1. 走らないで $ npm i -g vue-cli vue-cli 3.xが@ vue/cliに変更されたため。

  2. Vue-cli update issue は、npmまたはyarnのいずれかを使用してvue-cliをアップグレードできることを示しています。ただし、nvm内で作業する場合、yarnコマンドyarn global add @vue/cli 動作しませんでした。 nvmを使用しない場合は、yarnを介したインストールが機能する可能性があります。しかし、私はこれを確認しませんでした。

20
Antony

最初に現在のvueバージョンをアンインストールします

npm uninstall -g vue-cli

次にvueをインストールします

npm install -g @vue/cli

2
Chinthaka Dilan
npm install -g @vue/cli

OR

yarn global add @vue/cli
0
roli roli