webdevqa.jp.net

Ubuntuでのlibevent開発ライブラリのインストール

私は、ubuntu 10.10を使用して、libevent開発ライブラリlibevent1およびlibevent2をインストールしようとしています。私は以下のコマンドを使用しました

apt-get install libevent-dev libevent1-dev

But it shows-
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libevent1-dev

次に、私はapt-get install libevent-devしかし、libevent-devはすでに最新バージョンであると述べています。それはlibevent2ですか?私はrootユーザーです。私は何か悪いことをしていますか? Ubuntu 10.10はlibevent2をサポートしていますか?本当にあなたの助けに感謝します。ありがとう

11
saz

はい、libevent-devはlibevent2をインストールします。インストール時にapt-getの内容を確認すると、次のようになります。

apt-get install libevent-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libevent-core-2.0-5 libevent-extra-2.0-5 libevent-openssl-2.0-5 libevent-pthreads-2.0-5
The following NEW packages will be installed:
  libevent-core-2.0-5 libevent-dev libevent-extra-2.0-5 libevent-openssl-2.0-5 libevent-pthreads-2.0-5

Libeventの2.0.xバージョンに注意してください。

31
Jure Triglav