webdevqa.jp.net

ubuntuシステムにpython 2.6のsqlite3モジュールをインストールする際の問題

Sqlite3モジュールをubuntuシステムのpython 2.6で実行する必要があります。このモジュールをPython 2.6にインストールするにはどうすればよいですか?

どういうわけか私はこのモジュールを持っていません、それはエラーを引き起こします:

Python 2.6.5 (r265:79063, Mar 20 2010, 18:48:10) 
[GCC 4.4.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import sqlite3
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.6/sqlite3/__init__.py", line 24, in <module>
    from dbapi2 import *
  File "/usr/local/lib/python2.6/sqlite3/dbapi2.py", line 27, in <module>
    from _sqlite3 import *
ImportError: No module named _sqlite3
1
Hoang Pham

ファイル "/usr/local/lib/python2.6/sqlite3/__init__.py"、24行目

これは、Ubuntuに付属しているpython)ではありません。

  • インストールlibsqlite3-devそしてそのバージョンのPythonを再構築するか、または
  • / usr/bin/pythonを使用します
3
user23307

実行しているUbuntuのバージョンにもよりますが、おそらくSudo aptitude install python2.6-sqliteです。定期的に更新しない場合は、最初にパッケージを更新する必要があります(Sudo aptitude update)。


適切なsqlite3パッケージがインストールされていますか? dpkg -l | egrep sqlite3を実行すると、sqlite3libsqlite3-0を含む少なくとも3つのパッケージが表示されると思います。 python2.6-pysqlite2も必要になる場合があります。

Sudo aptitude install python2.6-pysqlite2 sqlite3 libsqlite3-0をお試しください

1
Cry Havok