webdevqa.jp.net

次のモジュールは、最適化を有効にして、またはデバッグ情報なしで構築されました

デバッグ時にVS 2008 Webプロジェクトでこれを取り除くことはできません。問題の非Webプロジェクトでデバッグモードになっており、Active(Debug)にあることを確認しました。 Windowsの.NET 2.0 tempフォルダー内のすべてのアイテムを削除しました。ここで他に何をすべきかわからない。

138
Anonymous

[ツール/オプション/デバッグ/オプション]で[マイコードのみを有効にする]を無効にしてみてください。

私は同じ問題を抱えていて、ビルドでデバッグ情報を出力していないことを発見しました。プロジェクトを右クリックして「プロパティ」に移動し、「ビルド」タブを選択すると、ページの下部に「詳細...」ボタンが表示され、デバッグ情報を出力するための設定が表示されます。それを「full」に設定すると、エラーは消えます。

enter image description here

79
Geert

私はこの問題に出くわしましたが、投稿された他の回答は私には当てはまらないとすぐに判断しました。

disable

私はプロジェクトの所有者であり、最適化なしでデバッグ情報を使用して構築されたことを知っています。さらに、最初の選択肢として警告の無効化を選択することは決して幸せではありません。この警告の非表示/無視は、今後のデバッグセッションで問題になる可能性があります。

これは、私が アセンブリに署名 の後にのみ発生し始めたため、これにより私のクイックフィックスがわかりました。DLL(および消費EXE)の厳密な名前を一時的に削除します。出来上がり!問題が解決しました。

より良い、長期的なソリューションは、ビルド後のアクションを追加して GAC を更新し、署名済みDLLの最新バージョンを保持するという形を取ることができます。

しかし、今のところ、この転換から先に進んで、このデバッグセッションに至った問題について引き続き作業を進めていきます。

24
Gustavo Mori

解決しました。問題のdllのすべての発生(すべてのプロジェクト)を削除しました。

17
Anonymous

VS2012、クリーンと再構築は私のために問題を修正しました。 [プロパティ]-> [ビルド]->コードの最適化はオフになっています。 「プロパティ」->「ビルド」->「詳細設定」->デバッグ情報:完全

14
user2892396

このリンクをご覧ください

http://social.msdn.Microsoft.com/Forums/en-US/vsdebug/thread/43cb16ba-0759-42ab-8e7d-9f168ace3b6f

「ツール」->「オプション」->「デバッグ」->「一般」で「Just My Code」のチェックを外してみてください。

わたしにはできる

10
raksham

VS 2008がdllを正しく再構築していないと推測します。

1)すべてのdllを削除します

2)ソリューションの再構築

そしてそれはそれを修正するはずです。

7
Nemo

この問題も同様に発生しますが、何らかの理由で3回または4回発生しました。 Visual Studio 2005のバグ/ヒックアップ(または少なくとも私のインストール)である必要があります。

これは毎回うまくいきました:修正するには

  1. ソリューションを右クリックして、[プロパティ]をクリックします。
  2. 構成マネージャーを開きます。
  3. ドロップダウンメニューで[デバッグ]を選択します(まだ選択されていない場合)。
  4. BUILDのチェックを外します。その後、再確認してください。
  5. ソリューションを再構築します。
6
Dave

他のすべてが失敗した場合は、プロジェクトのプロパティでアセンブリ名の名前を変更してみてください。これで問題が解決しました。

6
Sam Neirinck

ビルド構成オプションを確認してください。最適化がオフになっており、DEBUG定数が定義されていることを確認してください。

6
lc.

[ツール]> [オプション]> [デバッグ]> [シンボル]> [除外モジュールの指定]は、dllまたはexeが除外モジュールリストにある場合に表示されます

4
Raymond

特定のフォルダーのソリューションでこの問題が発生しましたが、別のフォルダーに移動したり、他のフォルダーで作成した場合、メッセージが表示されませんでした。クリーンアップ、再構築、再起動を行っても、このメッセージなしでは元のデバッグを取得できませんでした。エラーの原因となったファイルのコピーをシステムで検索したところ、コピーが保存されていることがわかりました

c:\ User\username\AppData\Local\Assembly\dl3

これはWin7-64で行われましたが、他のWindows OSでも同様です。そこで見つけたコピーをすべて削除しましたが、メッセージが表示されなくなりました。 [Enable Just My Code]のチェックを外す必要はありませんでした。

また、これはWPFアプリ用でしたが、検索でこのスレッドに出くわしたので、他の人の助けになることを願っています。

3
dragonwolf

少なくとも非Webアプリケーションではこれが機能します:

From: http://www.stellarpc.com/articles/board.aspx?id=4

2-デバッグを許可...

アプリケーションでアセンブリの1つがビルドされているという性質のため、Visual Studioデバッガーでコードを処理できるようにいくつかの設定を変更する必要があります。

ソリューションエクスプローラーから問題のプロジェクトを右クリックし、[プロパティ]を選択します。これにより、プロジェクトプロパティパネルが開き、プロジェクトの非常に多くのオプションにアクセスできます。 [コンパイル]タブ(またはC#環境の場合は[ビルド])に移動し、画面の下部から[高度なコンパイルオプション...]を選択します。これにより、2つの重要な関心領域があるプロンプトが表示されます。

1)最適化-「最適化を有効にする」のチェックを外します

2)デバッグ情報を生成する-オプションが「フル」に設定されていることを確認します

3
uzbones

次の手順に従うことで、この問題を解決できました。

  1. (プロジェクトではなく)ソリューションを右クリックし、「プロパティ」を選択します
  2. 左側のパネルで、「構成プロパティ」を選択します
  3. 右側のパネルで、プロジェクトの「構成」列の下にある「デバッグ」を選択します

ソリューションエクスプローラーにソリューションが表示されない場合は、次の手順を実行します。

  1. メニューバーで、[ツール]-> [オプション]に移動します。
  2. 左側のパネルで、[プロジェクトとソリューション]を選択します(ウィンドウの左下にある[すべての設定を表示]をチェックする必要がある場合があります)
  3. 右側のパネルで、[常にソリューションを表示する]をオンにします

これがお役に立てば幸いです。

3

別のサブネットに属するコンピューター上のアプリケーションをリモートデバッグしようとしたときに、これがありました。マシンが同じサブネット上にある場合、ネットワーク上でコードを実行するときに、コードをデバッグおよびステップスルーできました。サブネットを変更した後、ネットワークから実行しているときにステップスルーできず、「次のモジュールは最適化を有効にして、またはデバッグ情報なしで構築されました」を取得していました。

ソリューション?簡単です。構築したソリューションをリモートデバッグをホストしているマシンにコピーし、ローカルで実行します。

2
dr.blowfin

私もこれらすべてを持っています。そして、私はすべてこれをやった。これは、ソース管理からソリューション全体の新しいコピーを取得するたびに発生するようです。これらすべてを行った場合、Webプロジェクトのすべての参照(アセンブリ)のdllおよび.pdbファイルを削除し、ソリューションのクリーンオプションを使用し、一時ファイルを削除し、VSを閉じて再度開き、デバッグモードが選択されていることを確認します完全に設定されており、最適化はオフになっています。他に何がありますか?!?!?!

2
PositiveGuy

VS 2010 winFormsプロジェクトでこれが発生した場合。ここにいる人々の大半がWebプロジェクトを持っていることを見て、プロジェクトが保存されているフォルダーへのアクセスに関係していると思います。これは、この問題が発生したときに、Googleドライブがプロジェクトを保持しているフォルダーを同期していたためです。同期を無効にしても問題は解決しないようです。

私の解決策は、上記の答えの1つに似ています。

  • 「プロジェクトのプロパティ>コンパイル>高度なコンパイルオプション」に進みました
  • 「最適化を有効にする」にチェックを付けました
  • 「一般デバッグ情報:」を「なし」に設定します
  • 未チェックの「DEBUG定数を定義」
  • OKを押しました
  • その後、戻ってオプションを初期状態に戻しました。

これがまだ起こるように思われるので、これが誰かを助けることを願っています。

2
Macovei Vlad

Visual Studio 2010のWebプロジェクトでも同じ問題が発生し、最終的にこのメッセージが表示される理由を見つけました。 Visual Studioの既存のデバッグオプションを変更しました。

  • [ツール]-> [オプション]-> [デバッグ]-> [シンボル]-> [すべてのモジュール]に移動します。
  • 「除外しない限り」ラジオボタンをチェックします
  • [除外されたモジュールを指定]リンクをクリックし、デバッグするDLLを削除します。

私の場合、それは私のウェブdllファイルでした...

2
Ernesto Ibarra

私は同じ問題を抱えていますが、原因と解決策は異なります。ウィンドウはGustavo(上記)で表示されたものと同じでしたが、パスは次のとおりでした:"\ users\zzz\AppSettings ..."(zzzはWindowsユーザー名)

Excelアドインがありました-アドインのインストールをテストしていたため、VSインストール機能を介してコピーをインストールしました。 VSは明らかに、インストールされたコピーと起動したばかりのコピーの両方をデバッグしようとしていたため、インストールされたコピー上でデバッグシンボルを見つけることができませんでした。

上記のソリューションはどれも機能しませんでした(副作用なし)、

SOLUTION:アドインをアンインストールし、App Settingsのファイルを手動で削除しました。

1
SeeMoreGain

これに従ってください:(最初のSTOPデバッグ)
1:右クリック プロジェクトソリューション名 または 事業 -> 物性
2:下 構成プロパティ 選択する 構成マネージャー
3:変更 設定 に デバッグ をクリックします 閉じる
4:変更 設定 に デバッグ をクリックします 適用-> OK
今すぐソリューションを再構築してください...!

1
Yogesh Gat

私にとっては、プロジェクトプロパティの[コードの最適化]チェックボックスをオンにして、保存、チェック解除してから、再保存してくれました。

「Just My Codeを有効にする」を無効にすることもできましたが、その設定は必要ないので、修正というよりは回避策でした。

1
adam0101

ケース:SharePoint開発でコンソールプロジェクトを使用してアセンブリをテストする-SharePoint開発を行っており、VSでこのアラートが表示されている場合は、コンソールアプリをテストする前にSPアセンブリをGACに展開してくださいSPプロジェクトには、コンソールテストアプリで呼び出す必要があるメソッドがあります。

0
Andrew Rigney

私の場合は次のとおりです。webserviceはlib1.dllを参照しました。後で使用されなくなったため、後で参照を削除しました。ただし、lib1.dllはbinフォルダーに残りました。ライブラリが参照されなかったため、再構築およびクリーンアクションは役に立ちませんでした。 lib1.dllをbinフォルダーから手動で削除した後、このメッセージを取り除きました。

0
robsosno

再構築してからデバッグしてください。

0
tripdubroot

リリース構成でビルドした後、同じ問題が発生しました。デバッグに戻ったとき、VSは違いを検出していなかったため、binフォルダーの.dllファイルと.pdbファイルを更新していませんでした。

ここに私のために働いたものがあります:

  1. Iisresetを実行します(一時フォルダーをクリーンアップするため)
  2. Web.configを保存します(VSに実際に再構築させる)
  3. デバッグ時に再構築
  4. プロジェクトを開始する
0
bubbassauro

付け加えると、私はこのブログを見て、私が直面していた同じ問題の解決策を見つけていました。残念ながら、上記の解決策は役に立たなかった。ついに、インストーラーを介して(.pdbと共に)ビットをインストールし、インストールフォルダーに明示的にアクセス許可を設定しました。

その理由は、ファイルブラウザーが正しいファイルを表示しているにもかかわらず、VSがpdbをロードできなかったにもかかわらず、上記と同じエラーが発生したためです。

「自分のコードだけを有効にする」のチェックを外し、インストーラーから権限設定を削除すると、VSはモジュールのロードを開始しました。

0
self_noted

私のために働いた1つの構成は次のとおりでした

[プロジェクト]->(プロジェクト)プロパティ-> [デバッグ]タブ[構成]が[アクティブ(デバッグ)]に設定されていることを確認します。

0
tmez

私にとっては、一時的なasp.netファイル内のすべてのファイルを削除し、ソリューションを閉じてから再度開くと正常に動作します

0
Ahmad Alaa

IISに公開し、ビルトインWebサーバーを使用しない場合、またはIISエクスプレスを使用する場合は、公開プロファイル設定がデバッグモードであることを確認してください。 vs 11では、デフォルトでリリースモードになっています。

0
Galilyou

あなたはそれがウェブプロジェクトだと言いました...持っていますか

<compilation debug="true />

あなたのweb.configで?

0
Jonas

プロジェクトでこの問題が発生しましたが、AssemblyInfo.csの次の行をコメントアウトすると問題が修正されました。

[Assembly: Debuggable(DebuggableAttribute.DebuggingModes.IgnoreSymbolStoreSequencePoints)]
0
Mike Cheel

私はWindowsサービスを作成していますが、これが私のために働いたものです:

  • サービスをアンインストールします。
  • コマンドプロンプトを開き、c:\ Windows\Microsoft.NET\Framework64\v4.0.30319に移動します
  • installutil C:\ MyFantabulusWindowService\bin\Debug\MyFantabulusWindowService.exe

偉大さが達成されました!

0
Jack Nichols

これはSVNのリポジトリチェックアウトで行ったもので、プロジェクトのソースコードが徐々にソリューションに追加されました。

ソリューションは次のようになりました

solution
- project 1
  - Reference '..\assemblies\<companyname>.Customers.Adapter1.dll'
- project 2
  - Reference '<companyname>.Customers.Adapter1.dll' (project reference).
- project '<companyname>.Customers.Adapter1'

解決するには:

  • プロジェクト1で、アセンブリフォルダーdllへの参照を削除します。

  • プロジェクト1で、プロジェクト参照を「.Customers.Adapter1」に追加します。

0
mathijsuitmegen