webdevqa.jp.net

Windows Phone8.1エミュレーターがOSをロードしていません

エミュレーター(エミュレーター8.1 WVGA4インチ512MB、または実際にはその他)を起動しようとしていますが、起動に失敗します。

「OSの読み込み」画面に移動し、「DEP6100」というテキストのエラーボックスをスローします。 VSでは、下部に表示されます

Error1 Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device': ObjectDisposedException - 0x80131622

そして

Error2 Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device': ObjectDisposedException - 0x80131622

インターネットで調べましたが、まだ答えが見つかりませんでした。手伝ってもらえますか?

必要な追加情報を教えてください。

10

Windows8.1とVisualStudio 2013 Update3の新規インストールでも同じ問題が発生しました。

最初に、Microsoftのすべての要件を確認し、MSDNで見つかった問題の手順を提案しました: Windows Phone8用のWindowsPhoneエミュレーター

要件を満たしていることを確認した後、考えられる修正案のいずれも問題を修正しなかったので、次のことを試しました。これにより、エミュレーターで発生したエラーが修正されました。

私は次の方法で問題を修正しました:

  • VisualStudioを閉じる
  • 「コントロールパネル」に移動します
  • 「プログラムと機能」の選択
  • リストから「WindowsPhone8.1エミュレーター-ENU」を見つけます
  • 上部の「変更」ボタンをクリックするか、右クリックして「変更」を選択します
  • 表示される「VisualStudio」ウィンドウ。 「修復」を選択します
  • プロセスが完了するのを待ってから、VisualStudioを再度開きます
  • エミュレータを再度実行すると、今回は動作します。

変更を有効にするためにVisualStudioを開いたままにした場合は、PCを再起動する必要がある場合があります。幸運を!

12
madbrendon

私は同じ問題を抱えていました。最初に私はそれを修正しました:

  • ウィンドウの更新

  • Windows Phone SDK8のアンインストール/インストール

  • Hyper-vを削除して再度追加します(おそらく必要ありません)

しかし、問題が再発し、以前の解決策の代わりに、次の問題を修正しました:

  • windowsファイアウォールに移動し、[デフォルトに戻す]をクリックします
1
peyman gilmour

マカフィーをインストールするとエミュレータがブロックされたようです...エミュレータをアンインストールしてデフォルトのファイアウォール設定を復元しましたが、今のところ機能しています...

1
koko

http://daxdude.blogspot.com/2015/01/error-dep6100-bootstrapping-0x80131622.html を参照してください。問題は解決する可能性があります。

1
Secret

プロセッサがエミュレータを実行するために必要な要件をサポートしていることを確認してください。数時間試した後、私はついにチェックしました...そして私が持っているプロセッサは少なくとも1つの要件をサポートしていません。

実行coreinfo -v --available here --EPT(Intelの場合)またはNPT(AMDの場合)の横にある*を探しています。 -が表示されている場合は、別のプロセッサが必要です。幸運を!

0
Kevin Pope

私はあなたと同じ問題を抱えていました、そして多くの試みの後にそれをこのように解決しました:

  1. Hyper-Vを非アクティブ化します(そしてコンピューターを再起動します)。
  2. デバイスマネージャに移動してネットワークアダプタを開きます。ここでアンインストールしますすべて「Hyper-V ...」という名前で、これにより競合なしでHyper-Vを再アクティブ化できます。
  3. Hyper-Vを有効にします(そしてコンピューターを再起動します)。

最後にエミュレーターを起動します(初めて起動する場合は5〜10分待つ必要があるため、しばらくお待ちください。必要なすべてのアプリが読み込まれるのを待ちます)。

0
Niccolo Sacchi

Windows 10エミュレーターの場合10.0.1.0(1081p 2gb)

C:\ Users\MyUserName\AppData\Local\Microsoft\XDE\10.0.1.0 \にあるすべての(VHDおよびAVHD)ファイルを削除する必要があります。

エミュレータが再起動すると、すべてが再作成されます。 MyUserNameをユーザー名に置き換えます。他のエミュレーターでも機能するはずです。またね :)

0
FreshX