webdevqa.jp.net

OS X 10.10 YosemiteにXCode 7.3をインストールできますか?

理由により、OS Xを10.11にアップグレードできません。 XCode 7.3は、Yosemite 10.10と互換性のない最初のXCodeのようです。

XCode 7.3をYosemiteで動作させることに成功した人はいますか? (Xcodeの重要な更新であるhasは、Yosemiteとの互換性をなくしますか?)

12
Thyselius

残念ながら、できません。

3月21日以降、OS X 10.11以降(El Capitan)が必要です。

したがって、YosemiteからEl Capitanに更新するか、現在のXcodeを使用してください。

重要? iOS 9.3とSwift 2.2、もしあなたが好きなら... OSの残りの部分で、残りはほとんど同じです、それはそうではありませんメジャーアップデート。

12
Helen Wood

デバイス(iPhone、Apple TVなど)を更新し、この更新されたデバイスにアプリをエクスポートできなくなったためにここにいる場合、回避策があります!

実際に、iOS XCode SDKの最新バージョンをXCodeの新しいバージョンから古いバージョンのXCodeにコピーできます。

1古いXCode.appの名前をXCode7.appに変更し、XCodeの最新バージョンをインストールします(はい、複数のバージョンを使用できます)

2新しいXCodeパッケージコンテンツフォルダーのフォルダーを取得します:/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.3 \

そして、XCode 7.3または8.2バージョンの同じ場所に追加します/Applications/Xcode7.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

XCodeを再起動すると、作業を続けることができます!

0
Thyselius